Re: [PATCH V5 07/10] io_uring: switch to kernel_worker
From: Christian Brauner
Date: Mon Nov 22 2021 - 05:02:40 EST
On Sun, Nov 21, 2021 at 11:17:11AM -0700, Jens Axboe wrote:
> On 11/21/21 10:49 AM, Mike Christie wrote:
> > Convert io_uring and io-wq to use kernel_worker.
> I don't like the kernel_worker name, that implies it's always giving you
> a kernel thread or kthread. That's not the io_uring use case, it's
> really just a thread off the original task that just happens to never
> exit to userspace.
> Can we do a better name? At least io_thread doesn't imply that.
Yeah, I had thought about that as well and at first had kernel_uworker()
locally but wasn't convinced. Maybe we should just make it