[PATCH v2 0/9] refcount: Improve code-gen

From: Peter Zijlstra
Date: Fri Dec 10 2021 - 11:27:42 EST


Hi,

Now with Linus' favourite refcount scheme on :-)

Changes since RFC:

- more cleanups in scripts/atomic/
- rename atomic_*_ofl() to atomic_*_overflow() (null)
- alternative x86 refcount scheme (Linus)
- fix for refcount_dec_not_one()
- opt __refcount_add_not_zero(.i=1)

Boots x86_64 and builds a kernel.