Re: [PATCH -next, v2] sched: Use struct_size() helper in task_numa_group()

From: Peter Zijlstra
Date: Tue Jan 11 2022 - 06:31:11 EST


On Mon, Jan 10, 2022 at 07:31:58PM -0500, Steven Rostedt wrote:
> On Mon, 10 Jan 2022 23:46:15 +0100
> Peter Zijlstra <peterz@xxxxxxxxxxxxx> wrote:
>
> > On Mon, Jan 10, 2022 at 09:23:54AM +0800, Xiu Jianfeng wrote:
> > > Make use of struct_size() helper instead of an open-coded calculation.
> > > There is no functional change in this patch.
> > >
> > > Link: https://github.com/KSPP/linux/issues/160
> > > Signed-off-by: Xiu Jianfeng <xiujianfeng@xxxxxxxxxx>
> > > ---
> > > kernel/sched/fair.c | 5 ++---
> > > 1 file changed, 2 insertions(+), 3 deletions(-)
> > >
> > > diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
> > > index 095b0aa378df..af933a7f9e5d 100644
> > > --- a/kernel/sched/fair.c
> > > +++ b/kernel/sched/fair.c
> > > @@ -2437,9 +2437,8 @@ static void task_numa_group(struct task_struct *p, int cpupid, int flags,
> > > int i;
> > >
> > > if (unlikely(!deref_curr_numa_group(p))) {
> > > - unsigned int size = sizeof(struct numa_group) +
> > > - NR_NUMA_HINT_FAULT_STATS *
> > > - nr_node_ids * sizeof(unsigned long);
> > > + unsigned int size = struct_size(grp, faults,
> > > + NR_NUMA_HINT_FAULT_STATS * nr_node_ids);
> >
> > Again, why?! The old code was perfectly readable, this, not so much.
>
> Because it is unsafe,

Unsafe how? Changelog doesn't mention anything, nor do you. In fact,
Changelog says there is no functional change, which makes me hate the
thing for obscuring something that was simple.

> And to be honest, the new change is a lot easier to read than the original
> code.

I find it the other way around, because now I need to find and untangle
the unholy mess that is struct_size(), whereas currently it is trivial
C.