[PATCH 0/4] rtw88: four small code-cleanups and refactorings

From: Martin Blumenstingl
Date: Fri Jan 14 2022 - 18:49:17 EST


Hello,

this series consists of four small patches which clean up and refactor
existing code in preparation for SDIO support. Functionality is
supposed to stay the same with these changes.

The goal of the first two patches is to make it easier to understand
the allowed values in the queue by using enum rtw_tx_queue_type instead
of u8.

The third patch in this series moves the rtw_tx_queue_type code out of
pci.c so it can be re-used by SDIO (and also USB) HCIs.

The last patch is another small cleanup to improve readability of the
code by using (already existing) macros instead of magic BIT(n).

This series is built on top of v3 of my other series called "rtw88:
prepare locking for SDIO support" [0].


[0] https://lore.kernel.org/linux-wireless/20220108005533.947787-1-martin.blumenstingl@xxxxxxxxxxxxxx/


Martin Blumenstingl (4):
rtw88: pci: Change type of rtw_hw_queue_mapping() and ac_to_hwq to
enum
rtw88: pci: Change queue datatype from u8 to enum rtw_tx_queue_type
rtw88: Move enum rtw_tx_queue_type mapping code to tx.{c,h}
rtw88: mac: Use existing interface mask macros in rtw_pwr_seq_parser()

drivers/net/wireless/realtek/rtw88/mac.c | 4 +-
drivers/net/wireless/realtek/rtw88/pci.c | 47 ++++++------------------
drivers/net/wireless/realtek/rtw88/tx.c | 35 ++++++++++++++++++
drivers/net/wireless/realtek/rtw88/tx.h | 3 ++
4 files changed, 51 insertions(+), 38 deletions(-)

--
2.34.1