Re: [PATCH][next] staging: greybus: i2c: Use struct_size() helper in gb_i2c_operation_create()

From: Kees Cook
Date: Mon Jan 24 2022 - 17:14:44 EST


On Fri, Jan 21, 2022 at 04:22:50PM -0600, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.
>
> Also, address the following sparse warnings:
> drivers/staging/greybus/i2c.c:111:24: warning: using sizeof on a flexible structure
>
> Link: https://github.com/KSPP/linux/issues/174
> Signed-off-by: Gustavo A. R. Silva <gustavoars@xxxxxxxxxx>
> ---
> drivers/staging/greybus/i2c.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/staging/greybus/i2c.c b/drivers/staging/greybus/i2c.c
> index de2f6516da09..9dfc6791c20e 100644
> --- a/drivers/staging/greybus/i2c.c
> +++ b/drivers/staging/greybus/i2c.c
> @@ -108,9 +108,7 @@ gb_i2c_operation_create(struct gb_connection *connection,
> else
> data_out_size += (u32)msg->len;
>
> - request_size = sizeof(*request);
> - request_size += msg_count * sizeof(*op);
> - request_size += data_out_size;
> + request_size = struct_size(request, ops, msg_count) + data_out_size;

This could still overflow if struct_size() returns SIZE_MAX. Perhaps:

if (check_add_overflow(struct_size(request, ops, msg_count),
data_out_size, &request_size))
request_size = SIZE_MAX;

I should brush off the saturating arithmetic helpers series:
https://lore.kernel.org/all/20210920180853.1825195-1-keescook@xxxxxxxxxxxx/

>
> /* Response consists only of incoming data */
> operation = gb_operation_create(connection, GB_I2C_TYPE_TRANSFER,
> --
> 2.27.0
>

--
Kees Cook