Re: [PATCH v3 3/4] Watchdog: sp5100_tco: Add initialization using EFCH MMIO

From: Terry Bowman
Date: Mon Jan 24 2022 - 21:34:49 EST




On 1/24/22 11:36 AM, Jean Delvare wrote:
...
>> + res = request_mem_region(EFCH_PM_ACPI_MMIO_PM_ADDR,
>> + EFCH_PM_ACPI_MMIO_PM_SIZE,
>> + "sp5100_tco");
>> +
>> + if (!res) {
>> + dev_err(dev,
>> + "SMB base address memory region 0x%x already in use.\n",
>
> SMB -> SMBus
>

Yes, I will update.

>> + EFCH_PM_ACPI_MMIO_PM_ADDR);
>> + return -EBUSY;
>> + }
>> +
>> + addr = ioremap(EFCH_PM_ACPI_MMIO_PM_ADDR,
>> + EFCH_PM_ACPI_MMIO_PM_SIZE);
>> + if (!addr) {
>> + release_resource(res);
>> + dev_err(dev, "SMB base address mapping failed.\n");
>
> SMB -> SMBus
>

Yes, I will update.

>> + return -ENOMEM;
>> + }
>> +
>
> A short comment saying what the next command is doing would be
> appreciated.
>

I will add a brief comment explaining.

>> + if (!(efch_read_pm_reg8(addr, EFCH_PM_DECODEEN) &
>> + EFCH_PM_DECODEEN_WDT_TMREN)) {
>
> I find such splits hard to read. If checkpatch complains when you don't
> split it (but I think it no longer does, right?) then just introduce a
> local variable to store the register value. Same for the 2 occurrences
> below.
>

I will update for readability.

>> + efch_update_pm_reg8(addr, EFCH_PM_DECODEEN,
>> + 0xff,
>> + EFCH_PM_DECODEEN_WDT_TMREN);
>
> Easily fits in one fewer line.
>

I will change to 2 lines.

>> + }
>> +
>> + /* Determine MMIO base address */
>> + if (efch_read_pm_reg8(addr, EFCH_PM_DECODEEN) &
>> + EFCH_PM_DECODEEN_WDT_TMREN)
>> + mmio_addr = EFCH_PM_WDT_ADDR;
>> +
>> + /* Determine alternate MMIO base address */
>> + if (efch_read_pm_reg8(addr, EFCH_PM_ISACONTROL) &
>> + EFCH_PM_ISACONTROL_MMIOEN)
>> + alt_mmio_addr = EFCH_PM_ACPI_MMIO_ADDR +
>> + EFCH_PM_ACPI_MMIO_WDT_OFFSET;
>> +
>> + ret = sp5100_tco_prepare_base(tco, mmio_addr, alt_mmio_addr, dev_name);
>> + if (!ret) {
>> + tco_timer_enable_mmio(addr);
>> + ret = sp5100_tco_timer_init(tco);
>> + }
>> +
>> + iounmap(addr);
>> + release_resource(res);
>> +
>> + return ret;
>> +}
>> +
>> static int sp5100_tco_setupdevice(struct device *dev,
>> struct watchdog_device *wdd)
>> {
>> @@ -327,6 +410,9 @@ static int sp5100_tco_setupdevice(struct device *dev,
>> u32 alt_mmio_addr = 0;
>> int ret;
>>
>> + if (tco->tco_reg_layout == efch_mmio)
>> + return sp5100_tco_setupdevice_mmio(dev, wdd);
>> +
>> /* Request the IO ports used by this driver */
>> if (!request_muxed_region(SP5100_IO_PM_INDEX_REG,
>> SP5100_PM_IOPORTS_SIZE, "sp5100_tco")) {
>> diff --git a/drivers/watchdog/sp5100_tco.h b/drivers/watchdog/sp5100_tco.h
>> index adf015aa4126..2df8f8b2c55b 100644
>> --- a/drivers/watchdog/sp5100_tco.h
>> +++ b/drivers/watchdog/sp5100_tco.h
>> @@ -83,3 +83,8 @@
>>
>> #define EFCH_PM_ACPI_MMIO_ADDR 0xfed80000
>> #define EFCH_PM_ACPI_MMIO_WDT_OFFSET 0x00000b00
>> +#define EFCH_PM_ACPI_MMIO_PM_OFFSET 0x00000300
>> +
>> +#define EFCH_PM_ACPI_MMIO_PM_ADDR (EFCH_PM_ACPI_MMIO_ADDR + \
>> + EFCH_PM_ACPI_MMIO_PM_OFFSET)
>> +#define EFCH_PM_ACPI_MMIO_PM_SIZE 8
>
> Other than these minor details, patch looks good to me, thanks.
>
> Tested-by: Jean Delvare <jdelvare@xxxxxxx>
>

I'm finishing up revisions for this and the i2c patch. I expect to send both tomorrow.

Regards,
Teryr