Re: [PATCH][next] hwspinlock: sprd: Use struct_size() helper in devm_kzalloc()

From: Baolin Wang
Date: Tue Jan 25 2022 - 22:30:44 EST


On Wed, Jan 26, 2022 at 6:50 AM Gustavo A. R. Silva
<gustavoars@xxxxxxxxxx> wrote:
>
> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.
>
> Also, address the following sparse warnings:
> drivers/hwspinlock/sprd_hwspinlock.c:96:36: warning: using sizeof on a flexible structure
>
> Link: https://github.com/KSPP/linux/issues/174
> Signed-off-by: Gustavo A. R. Silva <gustavoars@xxxxxxxxxx>

LGTM.
Reviewed-by: Baolin Wang <baolin.wang7@xxxxxxxxx>

> ---
> drivers/hwspinlock/sprd_hwspinlock.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/hwspinlock/sprd_hwspinlock.c b/drivers/hwspinlock/sprd_hwspinlock.c
> index d221fc9d756d..22e2ffb91743 100644
> --- a/drivers/hwspinlock/sprd_hwspinlock.c
> +++ b/drivers/hwspinlock/sprd_hwspinlock.c
> @@ -93,8 +93,7 @@ static int sprd_hwspinlock_probe(struct platform_device *pdev)
> return -ENODEV;
>
> sprd_hwlock = devm_kzalloc(&pdev->dev,
> - sizeof(struct sprd_hwspinlock_dev) +
> - SPRD_HWLOCKS_NUM * sizeof(*lock),
> + struct_size(sprd_hwlock, bank.lock, SPRD_HWLOCKS_NUM),
> GFP_KERNEL);
> if (!sprd_hwlock)
> return -ENOMEM;
> --
> 2.27.0
>


--
Baolin Wang