Re: [PATCH] Adding architectural support for HPE's GXP BMC. This is the first of a series of patches to support HPE's BMC with Linux Kernel.

From: Krzysztof Kozlowski
Date: Wed Jan 26 2022 - 03:25:20 EST


On 25/01/2022 20:46, nick.hawkins@xxxxxxx wrote:
> From: Nick Hawkins <nick.hawkins@xxxxxxx>
>
> Signed-off-by: Nick Hawkins <nick.hawkins@xxxxxxx>
> ---
> .../devicetree/bindings/vendor-prefixes.yaml | 2 +
> MAINTAINERS | 8 +
> arch/arm/Kconfig | 2 +
> arch/arm/boot/dts/gxp.dts | 700 ++++++++++++++++++
> arch/arm/configs/gxp_defconfig | 243 ++++++
> arch/arm/mach-hpe/Kconfig | 20 +
> arch/arm/mach-hpe/Makefile | 1 +
> arch/arm/mach-hpe/gxp.c | 63 ++
> 8 files changed, 1039 insertions(+)
> create mode 100644 arch/arm/boot/dts/gxp.dts
> create mode 100644 arch/arm/configs/gxp_defconfig
> create mode 100644 arch/arm/mach-hpe/Kconfig
> create mode 100644 arch/arm/mach-hpe/Makefile
> create mode 100644 arch/arm/mach-hpe/gxp.c
>
> diff --git a/Documentation/devicetree/bindings/vendor-prefixes.yaml b/Documentation/devicetree/bindings/vendor-prefixes.yaml
> index 294093d45a23..e8b0ec874aed 100644
> --- a/Documentation/devicetree/bindings/vendor-prefixes.yaml
> +++ b/Documentation/devicetree/bindings/vendor-prefixes.yaml
> @@ -515,6 +515,8 @@ patternProperties:
> description: Jiangsu HopeRun Software Co., Ltd.
> "^hp,.*":
> description: Hewlett Packard

I guess this should be renamed/clarified to "Hewlett Packard
Incorporated", since these are two different companies.

Anyway, bindings go as separate patch, first in the series.

> + "^hpe,.*":
> + description: Hewlett Packard Enterprise
> "^hsg,.*":


Best regards,
Krzysztof