RE: [PATCH][next] Drivers: hv: vmbus: Use struct_size() helper in kmalloc()

From: Michael Kelley (LINUX)
Date: Thu Jan 27 2022 - 11:01:34 EST


From: Gustavo A. R. Silva <gustavoars@xxxxxxxxxx> Sent: Tuesday, January 25, 2022 10:02 AM
>
> Make use of the struct_size() helper instead of an open-coded version,
> in order to avoid any potential type mistakes or integer overflows that,
> in the worst scenario, could lead to heap overflows.
>
> Also, address the following sparse warnings:
> drivers/hv/vmbus_drv.c:1132:31: warning: using sizeof on a flexible structure
>
> Link: https://github.com/KSPP/linux/issues/174
> ---
> drivers/hv/vmbus_drv.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
> index 17bf55fe3169..cd193456cd84 100644
> --- a/drivers/hv/vmbus_drv.c
> +++ b/drivers/hv/vmbus_drv.c
> @@ -1129,7 +1129,7 @@ void vmbus_on_msg_dpc(unsigned long data)
> }
>
> if (entry->handler_type == VMHT_BLOCKING) {
> - ctx = kmalloc(sizeof(*ctx) + payload_size, GFP_ATOMIC);
> + ctx = kmalloc(struct_size(ctx, msg.payload, payload_size), GFP_ATOMIC);
> if (ctx == NULL)
> return;
>
> --
> 2.27.0

Reviewed-by: Michael Kelley <mikelley@xxxxxxxxxxxxx>