Re: [PATCH 2/2] perf arm-spe: Parse more SPE fields and store source

From: German Gomez
Date: Fri Jan 28 2022 - 12:22:53 EST


Hi Ali,

On 25/01/2022 19:20, Ali Saidi wrote:
> Decode more SPE events and op types to allow for processing by perf
> scripts. For example looking for branches which may indicate candidates
> for conversion to a CSEL, store exclusives that are candidates for
> conversion to LSE atomics and record the source information for memory
> ops.
>
> Signed-off-by: Ali Saidi <alisaidi@xxxxxxxxxx>
> ---
> .../util/arm-spe-decoder/arm-spe-decoder.c | 18 ++++++++++++++++++
> .../util/arm-spe-decoder/arm-spe-decoder.h | 8 ++++++++
> 2 files changed, 26 insertions(+)
>
> diff --git a/tools/perf/util/arm-spe-decoder/arm-spe-decoder.c b/tools/perf/util/arm-spe-decoder/arm-spe-decoder.c
> index 5e390a1a79ab..177bac0f7128 100644
> --- a/tools/perf/util/arm-spe-decoder/arm-spe-decoder.c
> +++ b/tools/perf/util/arm-spe-decoder/arm-spe-decoder.c
> @@ -191,6 +191,20 @@ static int arm_spe_read_record(struct arm_spe_decoder *decoder)
> decoder->record.op = ARM_SPE_ST;
> else
> decoder->record.op = ARM_SPE_LD;
> + if (SPE_OP_PKT_IS_LDST_ATOMIC(payload)) {
> + if (payload & SPE_OP_PKT_AT)
> + decoder->record.op |= ARM_SPE_LDST_ATOMIC;

In "utils/arm-spe.c" we check "if (record->op == ARM_SPE_LD)" so this
ORing could break some of the generated samples.

> + if (payload & SPE_OP_PKT_EXCL)
> + decoder->record.op |= ARM_SPE_LDST_EXCL;
> + if (payload & SPE_OP_PKT_AR)
> + decoder->record.op |= ARM_SPE_LDST_ACQREL;
> + }
> + } else if (idx == SPE_OP_PKT_HDR_CLASS_BR_ERET) {
> + decoder->record.op = ARM_SPE_BR;
> + if (payload & SPE_OP_PKT_COND)
> + decoder->record.op |= ARM_SPE_BR_COND;
> + if (SPE_OP_PKT_IS_INDIRECT_BRANCH(payload))
> + decoder->record.op |= ARM_SPE_BR_IND;
> }
> break;
> case ARM_SPE_EVENTS:
> @@ -218,8 +232,12 @@ static int arm_spe_read_record(struct arm_spe_decoder *decoder)
> if (payload & BIT(EV_MISPRED))
> decoder->record.type |= ARM_SPE_BRANCH_MISS;
>
> + if (payload & BIT(EV_NOT_TAKEN))
> + decoder->record.type |= ARM_SPE_BR_NOT_TAKEN;
> +
> break;
> case ARM_SPE_DATA_SOURCE:
> + decoder->record.source = payload;
> break;
> case ARM_SPE_BAD:
> break;
> diff --git a/tools/perf/util/arm-spe-decoder/arm-spe-decoder.h b/tools/perf/util/arm-spe-decoder/arm-spe-decoder.h
> index 69b31084d6be..113e427afe99 100644
> --- a/tools/perf/util/arm-spe-decoder/arm-spe-decoder.h
> +++ b/tools/perf/util/arm-spe-decoder/arm-spe-decoder.h
> @@ -22,11 +22,18 @@ enum arm_spe_sample_type {
> ARM_SPE_TLB_MISS = 1 << 5,
> ARM_SPE_BRANCH_MISS = 1 << 6,
> ARM_SPE_REMOTE_ACCESS = 1 << 7,
> + ARM_SPE_BR_NOT_TAKEN = 1 << 8,

Can you rename it to ARM_SPE_BRANCH_NOT_TAKEN for consistency?

> };
>
> enum arm_spe_op_type {
> ARM_SPE_LD = 1 << 0,
> ARM_SPE_ST = 1 << 1,
> + ARM_SPE_LDST_EXCL = 1 << 2,
> + ARM_SPE_LDST_ATOMIC = 1 << 3,
> + ARM_SPE_LDST_ACQREL = 1 << 4,
> + ARM_SPE_BR = 1 << 5,
> + ARM_SPE_BR_COND = 1 << 6,
> + ARM_SPE_BR_IND = 1 << 7,

I'm not sure if we should keep everything in one enum/bitmask. I'm also
looking at adding more of the data from the packets to the record, and
considering refactoring the record structure. I'll share here when I
have something.

Thanks,
German

> };
>
> struct arm_spe_record {
> @@ -40,6 +47,7 @@ struct arm_spe_record {
> u64 virt_addr;
> u64 phys_addr;
> u64 context_id;
> + u16 source;
> };
>
> struct arm_spe_insn;