Re: [PATCH v4 2/2] i2c: designware: Add AMD PSP I2C bus support

From: Jan Dąbroś
Date: Thu Feb 10 2022 - 10:05:30 EST


Hi,

czw., 10 lut 2022 o 15:43 Jarkko Nikula
<jarkko.nikula@xxxxxxxxxxxxxxx> napisał(a):
>
> On 2/10/22 10:18, Jan Dąbroś wrote:
> > śr., 9 lut 2022 o 16:28 Andy Shevchenko
> > <andriy.shevchenko@xxxxxxxxxxxxxxx> napisał(a):
> >>
> >> On Tue, Feb 08, 2022 at 03:12:18PM +0100, Jan Dabros wrote:
> >>
> >> ...
> >>
> >> I have noticed code duplication.
> >>
> >>> + status = psp_send_i2c_req(PSP_I2C_REQ_ACQUIRE);
> >>> + if (status) {
> >>> + if (status == -ETIMEDOUT)
> >>> + dev_err(psp_i2c_dev, "Timed out waiting for PSP to release I2C bus\n");
> >>> + else
> >>> + dev_err(psp_i2c_dev, "PSP communication error\n");
> >>> +
> >>> + dev_err(psp_i2c_dev, "Assume i2c bus is for exclusive host usage\n");
> >>> + psp_i2c_mbox_fail = true;
> >>> + goto cleanup;
> >>> + }
> >>
> >>> + /* Send a release command to PSP */
> >>> + status = psp_send_i2c_req(PSP_I2C_REQ_RELEASE);
> >>> + if (status) {
> >>> + if (status == -ETIMEDOUT)
> >>> + dev_err(psp_i2c_dev, "Timed out waiting for PSP to acquire I2C bus\n");
> >>> + else
> >>> + dev_err(psp_i2c_dev, "PSP communication error\n");
> >>> +
> >>> + dev_err(psp_i2c_dev, "Assume i2c bus is for exclusive host usage\n");
> >>> + psp_i2c_mbox_fail = true;
> >>> + goto cleanup;
> >>> + }
> >>
> >> If you are going to update the series, consider to introduce a common helper.
> >> Otherwise, consider a follow up.
> >
> > Thanks for your comment. Since Jarkko is running some long-lasting
> > tests with v4 patchset, I would like to keep this as is for now (and
> > make a follow up commit). If there will be some additional comments
> > for v4 from him and will spin v5 - I will introduce a common helper
> > function then.
> >
> Test run fine overnight, although I wasn't expecting this breaking
> Baytrail since patch is practically touching only semaphore detection at
> probe time on Baytrail. I'm up to you would you address Andy's comments
> as a follow up or as v5.
>
> Acked-by: Jarkko Nikula <jarkko.nikula@xxxxxxxxxxxxxxx>
> Tested-by: Jarkko Nikula <jarkko.nikula@xxxxxxxxxxxxxxx>

Thanks!

If you don't mind I'd prefer a merge and a follow-up improvement on
top. Current version is tested and in case of breakage it would be
easier to track.

Best Regards,
Jan