RE: [PATCH 03/49] net: mellanox: fix open-coded for_each_set_bit()

From: David Laight
Date: Fri Feb 11 2022 - 04:01:29 EST


From: Yury Norov
> Sent: 10 February 2022 22:49
>
> Mellanox driver has an open-coded for_each_set_bit(). Fix it.
>
> Signed-off-by: Yury Norov <yury.norov@xxxxxxxxx>
> Reviewed-by: Tariq Toukan <tariqt@xxxxxxxxxx>
> ---
> drivers/net/ethernet/mellanox/mlx4/cmd.c | 23 ++++++-----------------
> 1 file changed, 6 insertions(+), 17 deletions(-)
>
> diff --git a/drivers/net/ethernet/mellanox/mlx4/cmd.c b/drivers/net/ethernet/mellanox/mlx4/cmd.c
> index e10b7b04b894..c56d2194cbfc 100644
> --- a/drivers/net/ethernet/mellanox/mlx4/cmd.c
> +++ b/drivers/net/ethernet/mellanox/mlx4/cmd.c
> @@ -1994,21 +1994,16 @@ static void mlx4_allocate_port_vpps(struct mlx4_dev *dev, int port)
>
> static int mlx4_master_activate_admin_state(struct mlx4_priv *priv, int slave)
> {
> - int port, err;
> + int p, port, err;
> struct mlx4_vport_state *vp_admin;
> struct mlx4_vport_oper_state *vp_oper;
> struct mlx4_slave_state *slave_state =
> &priv->mfunc.master.slave_state[slave];
> struct mlx4_active_ports actv_ports = mlx4_get_active_ports(
> &priv->dev, slave);
> - int min_port = find_first_bit(actv_ports.ports,
> - priv->dev.caps.num_ports) + 1;
> - int max_port = min_port - 1 +
> - bitmap_weight(actv_ports.ports, priv->dev.caps.num_ports);
>
> - for (port = min_port; port <= max_port; port++) {
> - if (!test_bit(port - 1, actv_ports.ports))
> - continue;
> + for_each_set_bit(p, actv_ports.ports, priv->dev.caps.num_ports) {
> + port = p + 1;

This is an 'interesting' change in behaviour, and looks like a bug fix.
Did anyone actually test the old code?

David

-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)