Re: [PATCH] ath5k: use swap() to make code cleaner

From: Jiri Slaby
Date: Tue Feb 15 2022 - 00:40:00 EST


On 15. 02. 22, 1:51, davidcomponentone@xxxxxxxxx wrote:
From: Yang Guang <yang.guang5@xxxxxxxxxx>

Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.

Why don't you include that file then?

Reported-by: Zeal Robot <zealci@xxxxxxxxxx>
Signed-off-by: Yang Guang <yang.guang5@xxxxxxxxxx>
Signed-off-by: David Yang <davidcomponentone@xxxxxxxxx>
---
drivers/net/wireless/ath/ath5k/phy.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/net/wireless/ath/ath5k/phy.c b/drivers/net/wireless/ath/ath5k/phy.c
index 00f9e347d414..7fa7ba4952db 100644
--- a/drivers/net/wireless/ath/ath5k/phy.c
+++ b/drivers/net/wireless/ath/ath5k/phy.c
@@ -1562,16 +1562,13 @@ static s16
ath5k_hw_get_median_noise_floor(struct ath5k_hw *ah)
{
s16 sort[ATH5K_NF_CAL_HIST_MAX];
- s16 tmp;
int i, j;
memcpy(sort, ah->ah_nfcal_hist.nfval, sizeof(sort));
for (i = 0; i < ATH5K_NF_CAL_HIST_MAX - 1; i++) {
for (j = 1; j < ATH5K_NF_CAL_HIST_MAX - i; j++) {
if (sort[j] > sort[j - 1]) {
- tmp = sort[j];
- sort[j] = sort[j - 1];
- sort[j - 1] = tmp;
+ sort(sort[j], sort[j - 1]);
}
}
}


--
js
suse labs