Re: [PATCH V3 6/13] input: serio: use time_is_before_jiffies() instead of open coding it

From: Benjamin Tissoires
Date: Tue Feb 15 2022 - 03:48:44 EST


On Tue, Feb 15, 2022 at 2:57 AM Qing Wang <wangqing@xxxxxxxx> wrote:
>
> From: Wang Qing <wangqing@xxxxxxxx>
>
> Use the helper function time_is_{before,after}_jiffies() to improve
> code readability.
>
> Signed-off-by: Wang Qing <wangqing@xxxxxxxx>
> ---

Reviewed-by: Benjamin Tissoires <benjamin.tissoires@xxxxxxxxxx>

Cheers,
Benjamin

> drivers/input/serio/ps2-gpio.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/input/serio/ps2-gpio.c b/drivers/input/serio/ps2-gpio.c
> index 8970b49..7834296
> --- a/drivers/input/serio/ps2-gpio.c
> +++ b/drivers/input/serio/ps2-gpio.c
> @@ -136,7 +136,7 @@ static irqreturn_t ps2_gpio_irq_rx(struct ps2_gpio_data *drvdata)
> if (old_jiffies == 0)
> old_jiffies = jiffies;
>
> - if ((jiffies - old_jiffies) > usecs_to_jiffies(100)) {
> + if (time_is_before_jiffies(old_jiffies + usecs_to_jiffies(100))) {
> dev_err(drvdata->dev,
> "RX: timeout, probably we missed an interrupt\n");
> goto err;
> @@ -237,7 +237,7 @@ static irqreturn_t ps2_gpio_irq_tx(struct ps2_gpio_data *drvdata)
> if (old_jiffies == 0)
> old_jiffies = jiffies;
>
> - if ((jiffies - old_jiffies) > usecs_to_jiffies(100)) {
> + if (time_is_before_jiffies(old_jiffies + usecs_to_jiffies(100))) {
> dev_err(drvdata->dev,
> "TX: timeout, probably we missed an interrupt\n");
> goto err;
> --
> 2.7.4
>