Re: Bug 215744 - input from the accelerometer disappeared, regression on amd_sfh on kernel 5.17

From: Thorsten Leemhuis
Date: Mon Apr 04 2022 - 02:35:17 EST

On 01.04.22 21:47, Basavaraj Natikar wrote:
> Committed patch is disabling the interrupt mode and does not cause any
> functionality or working issues.

Well, for the reporter it clearly does cause problems, unless something
in testing went sideways.

> I also cross verified on 3 system and working fine on 5.17 and not able
> to reproduce or recreate.

> [...]

> ------------------------------------------------
> Looks like this is not regression. May be some hardware/firmware bug.

Well, from the point of the kernel development process it afaics is a
regression, unless the testing went sideways. It doesn't matter if the
root cause is in fact a hardware/firmware bug, as what matters in the
scope of the kernel development is: things worked, and now they don't.
For details please check this file and read the quotes from Linus:

Ciao, Thorsten

> Just curious reverting this patch how it is working just suspecting
> firmware undefined behavior.
> If possible, please check on other platform/system also if same behavior
> occurs.
> Could you please provide me platform/system details so that I can check
> this behavior?
> Thanks,
> Basavaraj
> On 4/1/2022 1:36 PM, Thorsten Leemhuis wrote:
>> Hi, this is your Linux kernel regression tracker.
>> I noticed a regression report in that afaics nobody
>> acted upon since it was reported about a week ago, that's why I decided
>> to forward it to the lists and all people that seemed to be relevant
>> here. It looks to me like this is something for Basavaraj, as it seems
>> to be caused by b300667b33b2 ("HID: amd_sfh: Disable the interrupt for
>> all command"). But I'm not totally sure, I only looked briefly into the
>> details. Or was this discussed somewhere else already? Or even fixed?
>> To quote from :
>>> Marco 2022-03-25 15:22:19 UTC
>>> After updating to 5.17, the input from the accelerometer disappeared, completely. No devices available from IIO tree. First bad commit causing it is Reverting this and the the other two on top fixed this. Tried to not revert only the above mentioned commit, but it's still not working.
>>> Marco.
>> Anyway, to get this tracked:
>> #regzbot introduced: b300667b33b2b5a2c8e5f8f22826befb3d7f4
>> #regzbot from: Marco <rodomar705@xxxxxxxxxxxxxx>
>> #regzbot title: input: hid: input from the accelerometer disappeared due
>> to changes to amd_sfh
>> #regzbot link:;;sdata=HbQ5LymDwsc94RZhNuzN83%2F0BUplqRUG7bB%2BXymViP0%3D&amp;reserved=0
>> Ciao, Thorsten (wearing his 'the Linux kernel's regression tracker' hat)
>> P.S.: As the Linux kernel's regression tracker I'm getting a lot of
>> reports on my table. I can only look briefly into most of them and lack
>> knowledge about most of the areas they concern. I thus unfortunately
>> will sometimes get things wrong or miss something important. I hope
>> that's not the case here; if you think it is, don't hesitate to tell me
>> in a public reply, it's in everyone's interest to set the public record
>> straight.