[PATCH 0/1] delay: rename fsleep to usleep_autoyield
From: Wolfram Sang
Date: Wed Apr 06 2022 - 08:56:30 EST
I recently stumbled over the relatively new function fsleep(). While I
think it is usful, I also think the name is too short to be
self-explanatory. This is why I suggest a rename before it gets even
wider use in the kernel. Once this rename is upstream, I will convert
the users. The churn is still in the acceptable range with 12 patches
and 70 lines changed IMO.
The name 'usleep_autoyield' is the best I could come up with, but if you
can think of something better I am all ears.
Please let me know what you think!
All the best,
Wolfram Sang (1):
delay: rename fsleep to usleep_autoyield
Documentation/timers/timers-howto.rst | 2 +-
include/linux/delay.h | 4 +++-
2 files changed, 4 insertions(+), 2 deletions(-)