Re: [Linux 5.18-rc1] WARNING: CPU: 1 PID: 0 at kernel/sched/fair.c:3355 update_blocked_averages

From: Dietmar Eggemann
Date: Wed Apr 06 2022 - 11:20:16 EST

On 05/04/2022 15:13, Ammar Faizi wrote:
> On 4/5/22 7:21 PM, Dietmar Eggemann wrote:
>> Tried to recreate the issue but no success so far. I used you config
>> file, clang-14 and a Xeon CPU E5-2690 v2 (2 sockets 40 CPUs) with 20
>> two-level cgoupv1 taskgroups '/X/Y' with 'hackbench (10 groups, 40 fds)
>> + idling' running in all '/X/Y/'.
>> What userspace are you running?
> HP Laptop, Intel i7-1165G7, 8 CPUs, with 16 GB of RAM. Ubuntu 21.10.
> Just for
> daily workstation. Compiling kernel, browsing and coding stuff.

Can you check that CFS Bandwidth control (CONFIG_CFS_BANDWIDTH=y) is
still not used on Ubuntu desktop 21.10?

It shouldn't but I can't verify since I'm still on 20.04 LTS Desktop:

$ mount | grep "cgroup2\|\bcpu\b"
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)

CPU controller is still used in cgroupv1. So cgroupv2 can't use it:

$ cat /sys/fs/cgroup/unified/cgroup.controllers
/* empty */

And there is no cgroupv1 hierarchy under /sys/fs/cgroup/cpu,cpuacct/ .

No cpu.cfs_quota_us files with something other than -1.

So CFS Bandwidth control is not used.