Re: [PATCH] memory: renesas-rpc-if: Simplify single/double data register access

From: Geert Uytterhoeven
Date: Tue Apr 12 2022 - 06:48:52 EST


Hi Wolfram,

On Tue, Apr 12, 2022 at 11:42 AM Wolfram Sang
<wsa+renesas@xxxxxxxxxxxxxxxxxxxx> wrote:
> On Mon, Apr 11, 2022 at 02:55:29PM +0200, Geert Uytterhoeven wrote:
> > For manual write and read, factor out the common access to the first
> > data register by keeping track of the current data pointer.
> >
> > Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx>
>
> Works fine with reading/writing on a V3U, so:
>
> Tested-by: Wolfram Sang <wsa+renesas@xxxxxxxxxxxxxxxxxxxx>
>
> I agree the code is more concise. I am not sure, though, if it is really
> more readable. But I don't mind very much, so except for a small nit:
>
> Reviewed-by: Wolfram Sang <wsa+renesas@xxxxxxxxxxxxxxxxxxxx>

Thanks!

> > + if (nbytes == 8)
> > + regmap_write(rpc->regmap, RPCIF_SMWDR1, *p++);
> > + regmap_write(rpc->regmap, RPCIF_SMWDR0, *p++);
>
> Last '++' can be omitted?

I know. But I think it looks nicer this way ;-)
The compiler doesn't care anyway.

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds