[PATCH] libnvdimm: use kobj_to_dev()

From: cgel . zte
Date: Mon Apr 25 2022 - 06:54:58 EST


From: Minghao Chi <chi.minghao@xxxxxxxxxx>

Use kobj_to_dev() instead of open-coding it.

Reported-by: Zeal Robot <zealci@xxxxxxxxxx>
Signed-off-by: Minghao Chi <chi.minghao@xxxxxxxxxx>
---
drivers/nvdimm/namespace_devs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/nvdimm/namespace_devs.c b/drivers/nvdimm/namespace_devs.c
index 62b83b2e26e3..e9f021da743c 100644
--- a/drivers/nvdimm/namespace_devs.c
+++ b/drivers/nvdimm/namespace_devs.c
@@ -1380,7 +1380,7 @@ static struct attribute *nd_namespace_attributes[] = {
static umode_t namespace_visible(struct kobject *kobj,
struct attribute *a, int n)
{
- struct device *dev = container_of(kobj, struct device, kobj);
+ struct device *dev = kobj_to_dev(kobj);

if (is_namespace_pmem(dev)) {
if (a == &dev_attr_size.attr)
--
2.25.1