Re: [PATCH v2 1/4] kunit: rename print_subtest_{start,end} for clarity (s/subtest/suite)

From: Brendan Higgins
Date: Sat Apr 30 2022 - 03:31:58 EST

On Fri, Apr 29, 2022 at 2:13 PM Daniel Latypov <dlatypov@xxxxxxxxxx> wrote:
> These names sound more general than they are.
> The _end() function increments a `static int kunit_suite_counter`, so it
> can only safely be called on suites, aka top-level subtests.
> It would need to have a separate counter for each level of subtest to be
> generic enough.
> So rename it to make it clear it's only appropriate for suites.
> Signed-off-by: Daniel Latypov <dlatypov@xxxxxxxxxx>
> Reviewed-by: David Gow <davidgow@xxxxxxxxxx>

Reviewed-by: Brendan Higgins <brendanhiggins@xxxxxxxxxx>