Re: [PATCH v2 00/48] ARM: PXA multiplatform support

From: Guenter Roeck
Date: Sat Apr 30 2022 - 08:41:42 EST

On 4/30/22 01:04, Arnd Bergmann wrote:
On Sat, Apr 30, 2022 at 1:09 AM Guenter Roeck <linux@xxxxxxxxxxxx> wrote:
On 4/29/22 14:46, Arnd Bergmann wrote:
On Fri, Apr 29, 2022 at 10:23 PM Guenter Roeck <linux@xxxxxxxxxxxx> wrote:
On 4/29/22 10:48, Guenter Roeck wrote:

I tried the pxa-multiplatform-5.18 branch. Its failures match
those in v5.18-rc1.

Uuh, wait, the build wasn't complete. There are still some
failures. I'll report later.

Sorry about the breakage, I got a few more reports about minor build errors
and warnings, the newly uploaded branches should address all of the ones
I got reports for.

Unless I am missing something the failures are the same as before. See

This is with v5.18-rc1-49-ge8ab9a9a2745 which is the tip of

Should I check a different branch ?

I only addressed the pcmcia probe failure that you reported for the
final pxa patch, which
previously caused a NULL pointer reference here:

[ 1.405319] PC is at pcmcia_init_one+0xf8/0x27c
[ 1.405476] LR is at devres_add+0x40/0x6c
[ 1.405611] pc : [<c04bdea0>] lr : [<c044d808>] psr: a0000113
[ 1.405846] sp : c48a5d00 ip : c15f4220 fp : 60000113
[ 1.406026] r10: 00000000 r9 : c48b000e r8 : c48b0000
[ 1.406195] r7 : feeb0000 r6 : feeb000e r5 : c15ec090 r4 : c15ec020
[ 1.406395] r3 : 00000002 r2 : 00000000 r1 : c15f4200 r0 : feeb000e

This now seems to work:

[ 1.435846] pcmcia_socket pcmcia_socket1: pccard: PCMCIA card
inserted into slot 1
[ 1.456350] pcmcia_socket pcmcia_socket0: pccard: PCMCIA card
inserted into slot 0
[ 1.457489] pcmcia 0.0: pcmcia: registering new device pcmcia0.0 (IRQ: 217)
[ 1.460275] pata_pcmcia: probe of 0.0 failed with error -12

So it sounds like there are additional bugs that I have to look at. I
probably won't
be able to do that in time for the merge window. The logs contain a number of
warnings, but I have no idea which ones of those are preexisting issue. I had
a look at

[ 0.689982] pxa-dma pxa-dma.0: error -ENXIO: IRQ index 1 not found

Yes, those messages are indeed old.

and concluded that it must have done this for a long time. In my own qemu
instance, I see a crash from iWMMXt, but that works fine on your machine.
OTOH, your failed instances all look like they either time out or
failed to find a
rootfs. I tried passing an MMC device as root, and that works here.

Booting from mmc works for me as well. Booting from pcmcia worked before,
so I assume that there must be some regression.