[PATCH net-next 1/5] net: dsa: realtek: rtl8365mb: rename macro RTL8367RB -> RTL8367RB_VB

From: Alvin Šipraga
Date: Mon Jun 06 2022 - 09:46:25 EST


From: Alvin Šipraga <alsi@xxxxxxxxxxxxxxx>

The official name of this switch is RTL8367RB-VB, not RTL8367RB. There
is also an RTL8367RB-VC which is rather different. Change the name of
the CHIP_ID/_VER macros for reasons of consistency.

Signed-off-by: Alvin Šipraga <alsi@xxxxxxxxxxxxxxx>
---
drivers/net/dsa/realtek/rtl8365mb.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/net/dsa/realtek/rtl8365mb.c b/drivers/net/dsa/realtek/rtl8365mb.c
index 3bb42a9f236d..0cc90e96aab7 100644
--- a/drivers/net/dsa/realtek/rtl8365mb.c
+++ b/drivers/net/dsa/realtek/rtl8365mb.c
@@ -108,8 +108,8 @@
#define RTL8365MB_CHIP_ID_8367S 0x6367
#define RTL8365MB_CHIP_VER_8367S 0x00A0

-#define RTL8365MB_CHIP_ID_8367RB 0x6367
-#define RTL8365MB_CHIP_VER_8367RB 0x0020
+#define RTL8365MB_CHIP_ID_8367RB_VB 0x6367
+#define RTL8365MB_CHIP_VER_8367RB_VB 0x0020

/* Family-specific data and limits */
#define RTL8365MB_PHYADDRMAX 7
@@ -2008,7 +2008,7 @@ static int rtl8365mb_detect(struct realtek_priv *priv)
"found an RTL8365MB-VC switch (ver=0x%04x)\n",
chip_ver);
break;
- case RTL8365MB_CHIP_VER_8367RB:
+ case RTL8365MB_CHIP_VER_8367RB_VB:
dev_info(priv->dev,
"found an RTL8367RB-VB switch (ver=0x%04x)\n",
chip_ver);
--
2.36.0