Re: [PATCH v4 5/6] arm64: mm: Convert to GENERIC_IOREMAP

From: Christoph Hellwig
Date: Mon Jun 06 2022 - 12:28:33 EST


On Mon, Jun 06, 2022 at 09:28:22PM +0800, Kefeng Wang wrote:
> As commit bdc48fa11e46  ("checkpatch/coding-style: deprecate 80-column
> warning") increased
>
> the limit to 100 columns,so I don't get warning when using checkpatch, and
> it is not a hard limit,

No, it did not increase the general limit, just for exception cases.
Block comments certainly don't fall under that, and while the mileage
on the defineѕ may vary it generally is more readable to have them
on the next line.

checkpath is unfortunately totall broken these days :(

>
> but if this is a mandatory requirement, I will resend them with break lines.
>
> > > +#define ioremap_cache(addr, size) ({ \
> > > + pfn_is_map_memory(__phys_to_pfn(addr)) ? \
> > > + (void __iomem *)__phys_to_virt(addr) : ioremap_prot(addr, size, PROT_NORMAL); \
> > > +})
> > And this really should be an inline function.
>
> We still need a define, see kernel/iomem.c,

You can just define it to the same name after the inline.