Re: [PATCH 2/4] fs/ntfs3: Rename bitmap_size() as ntfs3_bitmap_size()
From: Andy Shevchenko
Date: Sat Jul 02 2022 - 15:00:59 EST
On Sat, Jul 02, 2022 at 08:29:27PM +0200, Christophe JAILLET wrote:
> In order to introduce a bitmap_size() function in the bitmap API, we have
> to rename functions with a similar name.
...
> /* NTFS uses quad aligned bitmaps. */
> -static inline size_t bitmap_size(size_t bits)
> +static inline size_t ntfs3_bitmap_size(size_t bits)
> {
> return ALIGN((bits + 7) >> 3, 8);
It would be easier to understand in a way
return BITS_TO_BYTES(ALIGN(bits, 64));
> }
--
With Best Regards,
Andy Shevchenko