[PATCH v5 00/12] thermal OF rework

From: Daniel Lezcano
Date: Sun Jul 10 2022 - 08:35:26 EST


The thermal framework initialization with the device tree appears to
be complicated and hard to make it to evolve.

It contains duplication of almost the same thermal generic structures
and has an assymetric initialization making hard any kind of serious
changes for more complex features. One of them is the multiple sensors
support per thermal zone.

In order to set the scene for the aforementioned feature with generic
code, we need to cleanup and rework the device tree initialization.

However this rework is not obvious because of the multiple components
entering in the composition of a thermal zone and being initialized at
different moments. For instance, a cooling device can be initialized
before a sensor, so the thermal zones must exist before the cooling
device as well as the sensor. This asynchronous initialization forces
the thermal zone to be created with fake ops because they are
mandotory and build a list of cooling devices which is used to lookup
afterwards when the cooling device driver is registering itself.

As there could be a large number of changes, this first series provide
some steps forward for a simpler device tree initialization.

More series for cleanup and code duplication removal will follow.

Changelog:

- v5:
- Remove extra of_node_put() reported by lkp

- V4:
- Added of_node_put(trips)
- Changed naming 'ntrips' -> 'num_trips'
- Updated documentation for added and renamed fields in the thermal
zone structure
- Fixed bad parameter type 'thermal_zone' -> 'thermal_zone_device'
- Clarified there is more cleanups coming in the changelog
- Put 'trips' and 'num_trips' fields all together
- Made git-bisect safe the series

- V3:
- Removed patch 1 and 2 from the V2 which consist in renaming the
thermal_zone_device_ops to thermal_sensor_ops and separating the
structure. I'll do a separate proposal for that after the incoming
cleanups

- V2:
- Drop patch 1/15 which contains too many changes for a simple
structure renaming. This could be addressed in a separate series as
it is not necessary for the OF rework

- Fixed of_node_put with gchild not initialized as reported by
kbuild and Dan Carpenter

- V1:
- Initial post

Daniel Lezcano (12):
thermal/core: Remove duplicate information when an error occurs
thermal/of: Replace device node match with device node search
thermal/of: Remove the device node pointer for thermal_trip
thermal/of: Move thermal_trip structure to thermal.h
thermal/core: Remove unneeded EXPORT_SYMBOLS
thermal/core: Move thermal_set_delay_jiffies to static
thermal/core: Rename trips to ntrips
thermal/core: Add thermal_trip in thermal_zone
thermal/core: Register with the trip points
thermal/of: Store the trips in the thermal zone
thermal/of: Use thermal trips stored in the thermal zone
thermal/of: Initialize trip points separately

drivers/thermal/gov_fair_share.c | 6 +-
drivers/thermal/gov_power_allocator.c | 4 +-
drivers/thermal/tegra/tegra30-tsensor.c | 2 +-
drivers/thermal/thermal_core.c | 53 +++++--
drivers/thermal/thermal_core.h | 25 ++-
drivers/thermal/thermal_helpers.c | 13 +-
drivers/thermal/thermal_netlink.c | 2 +-
drivers/thermal/thermal_of.c | 201 +++++++++++++-----------
drivers/thermal/thermal_sysfs.c | 22 +--
include/linux/thermal.h | 24 ++-
10 files changed, 199 insertions(+), 153 deletions(-)

--
2.25.1