Re: [PATCH v4] netfs: do not unlock and put the folio twice

From: Xiubo Li
Date: Mon Jul 11 2022 - 00:19:49 EST

On 7/7/22 9:26 PM, Matthew Wilcox wrote:
On Thu, Jul 07, 2022 at 02:21:45PM +0100, David Howells wrote:
- struct folio *folio, void **_fsdata);
+ struct folio **_folio, void **_fsdata);
The usual convention is that _foo means "Don't touch". This should
probably be named "foliop" (ie pointer to a thing that would normally
be called folio).

This looks good to me.

I will send out the V5 by fixing this and will merge this patch via the ceph tree as discussed with David in the IRC and will cc the stable at the same time.


-- Xiubo