Re: [PATCH v5 00/12] thermal OF rework

From: Daniel Lezcano
Date: Sat Jul 16 2022 - 17:56:58 EST



Hi,

On 10/07/2022 14:34, Daniel Lezcano wrote:
The thermal framework initialization with the device tree appears to
be complicated and hard to make it to evolve.

It contains duplication of almost the same thermal generic structures
and has an assymetric initialization making hard any kind of serious
changes for more complex features. One of them is the multiple sensors
support per thermal zone.

In order to set the scene for the aforementioned feature with generic
code, we need to cleanup and rework the device tree initialization.

However this rework is not obvious because of the multiple components
entering in the composition of a thermal zone and being initialized at
different moments. For instance, a cooling device can be initialized
before a sensor, so the thermal zones must exist before the cooling
device as well as the sensor. This asynchronous initialization forces
the thermal zone to be created with fake ops because they are
mandotory and build a list of cooling devices which is used to lookup
afterwards when the cooling device driver is registering itself.

As there could be a large number of changes, this first series provide
some steps forward for a simpler device tree initialization.

More series for cleanup and code duplication removal will follow.

Changelog:

- v5:
- Remove extra of_node_put() reported by lkp

- V4:
- Added of_node_put(trips)
- Changed naming 'ntrips' -> 'num_trips'
- Updated documentation for added and renamed fields in the thermal
zone structure
- Fixed bad parameter type 'thermal_zone' -> 'thermal_zone_device'
- Clarified there is more cleanups coming in the changelog
- Put 'trips' and 'num_trips' fields all together
- Made git-bisect safe the series

If there is no more comments, I'll pick this series





--
<http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs

Follow Linaro: <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog