Re: [PATCH v2 3/4] dmaengine: stm32-dma: add support to trigger STM32 MDMA

From: Amelie Delaunay
Date: Tue Jul 19 2022 - 11:31:17 EST


Hi Marek,

Thanks for reviewing.

On 7/14/22 21:02, Marek Vasut wrote:
On 7/13/22 16:21, Amelie Delaunay wrote:

[...]

diff --git a/drivers/dma/stm32-dma.c b/drivers/dma/stm32-dma.c
index adb25a11c70f..3916295fe154 100644
--- a/drivers/dma/stm32-dma.c
+++ b/drivers/dma/stm32-dma.c
@@ -142,6 +142,8 @@
  #define STM32_DMA_DIRECT_MODE_GET(n)    (((n) & STM32_DMA_DIRECT_MODE_MASK) >> 2)
  #define STM32_DMA_ALT_ACK_MODE_MASK    BIT(4)
  #define STM32_DMA_ALT_ACK_MODE_GET(n)    (((n) & STM32_DMA_ALT_ACK_MODE_MASK) >> 4)
+#define STM32_DMA_MDMA_STREAM_ID_MASK    GENMASK(19, 16)
+#define STM32_DMA_MDMA_STREAM_ID_GET(n) (((n) & STM32_DMA_MDMA_STREAM_ID_MASK) >> 16)

Try FIELD_GET() from include/linux/bitfield.h

[...]


Yes, but not only on this new line. I'll add a prior patch to the patchset to use FIELD_{GET,PREP}() helpers every where custom macros are used.

@@ -1630,6 +1670,20 @@ static int stm32_dma_probe(struct platform_device *pdev)
          chan->id = i;
          chan->vchan.desc_free = stm32_dma_desc_free;
          vchan_init(&chan->vchan, dd);
+
+        chan->mdma_config.ifcr = res->start;
+        chan->mdma_config.ifcr += (chan->id & 4) ? STM32_DMA_HIFCR : STM32_DMA_LIFCR;
+
+        chan->mdma_config.tcf = STM32_DMA_TCI;
+        /*
+         * bit0 of chan->id represents the need to left shift by 6
+         * bit1 of chan->id represents the need to extra left shift by 16
+         * TCIF0, chan->id = b0000; TCIF4, chan->id = b0100: left shift by 0*6 + 0*16
+         * TCIF1, chan->id = b0001; TCIF5, chan->id = b0101: left shift by 1*6 + 0*16
+         * TCIF2, chan->id = b0010; TCIF6, chan->id = b0110: left shift by 0*6 + 1*16
+         * TCIF3, chan->id = b0011; TCIF7, chan->id = b0111: left shift by 1*6 + 1*16
+         */
+        chan->mdma_config.tcf <<= (6 * (chan->id & 0x1) + 16 * ((chan->id & 0x2) >> 1));

Some sort of symbolic macros instead of open-coded constants could help readability here.


I agree. As the same kind of computation is done in stm32_dma_irq_status() and stm32_dma_irq_clear(), I'll add another prior patch to the patchset to introduce new macro helpers to get ISR/IFCR offset depending on channel id, and to get channel flags mask depending on channel id.

[...]

Regards,
Amelie