Re: [PATCH V14 3/7] PCI/DOE: Add DOE mailbox support functions

From: Ira Weiny
Date: Tue Jul 19 2022 - 15:16:32 EST


On Tue, Jul 19, 2022 at 05:35:53PM +0100, Jonathan Cameron wrote:
> On Thu, 14 Jul 2022 20:04:20 -0700
> ira.weiny@xxxxxxxxx wrote:
>
> > From: Jonathan Cameron <Jonathan.Cameron@xxxxxxxxxx>
> >
> > Introduced in a PCIe r6.0, sec 6.30, DOE provides a config space based
> > mailbox with standard protocol discovery. Each mailbox is accessed
> > through a DOE Extended Capability.
> >
> > Each DOE mailbox must support the DOE discovery protocol in addition to
> > any number of additional protocols.
> >
> > Define core PCIe functionality to manage a single PCIe DOE mailbox at a
> > defined config space offset. Functionality includes iterating,
> > creating, query of supported protocol, and task submission. Destruction
> > of the mailboxes is device managed.
> >
> > Cc: "Li, Ming" <ming4.li@xxxxxxxxx>
> > Cc: Bjorn Helgaas <helgaas@xxxxxxxxxx>
> > Cc: Matthew Wilcox <willy@xxxxxxxxxxxxx>
> > Acked-by: Bjorn Helgaas <helgaas@xxxxxxxxxx>
> > Signed-off-by: Jonathan Cameron <Jonathan.Cameron@xxxxxxxxxx>
> > Co-developed-by: Ira Weiny <ira.weiny@xxxxxxxxx>
> > Signed-off-by: Ira Weiny <ira.weiny@xxxxxxxxx>
> Hi Ira,
>
> Thanks for persisting with this!
>
> So, I think this works, but there is at least one 'sleep' I can't
> see a purpose for. I think it's just a left over from refactoring.
>
> A few other more trivial things inline.
>
> Thanks,
>
> Jonathan
>
>
> >
> >> # Endpoint library must be initialized before its users
> > obj-$(CONFIG_PCI_ENDPOINT) += endpoint/
> > diff --git a/drivers/pci/doe.c b/drivers/pci/doe.c
> > new file mode 100644
> > index 000000000000..12c3762be22f
> > --- /dev/null
> > +++ b/drivers/pci/doe.c
> > @@ -0,0 +1,546 @@
> > +// SPDX-License-Identifier: GPL-2.0
> > +/*
> > + * Data Object Exchange
> > + * PCIe r6.0, sec 6.30 DOE
> > + *
> > + * Copyright (C) 2021 Huawei
> > + * Jonathan Cameron <Jonathan.Cameron@xxxxxxxxxx>
> > + *
> > + * Copyright (C) 2022 Intel Corporation
> > + * Ira Weiny <ira.weiny@xxxxxxxxx>
> > + */
> > +
> > +#define dev_fmt(fmt) "DOE: " fmt
> > +
> > +#include <linux/bitfield.h>
> > +#include <linux/delay.h>
> > +#include <linux/jiffies.h>
> > +#include <linux/mutex.h>
> > +#include <linux/pci.h>
> > +#include <linux/pci-doe.h>
> > +#include <linux/workqueue.h>
> > +
> > +#define PCI_DOE_PROTOCOL_DISCOVERY 0
> > +
> > +#define PCI_DOE_BUSY_MAX_RETRIES 16
> Left over from removed code.

I think Dan may have taken these. If so I'll send a clean up. If not I can
spin. Let me check.

>
> > +static int pci_doe_wait(struct pci_doe_mb *doe_mb, unsigned long timeout)
>
> This feels misnamed to me now. It's not waiting for the DOE, it's
> just sleeping unless we cancel. The actual poll / wait is handled
> outside this. pci_doe_sleep_unless_cancel() maybe?

It is waiting a timeout period _or_ checking if we are canceled.

So I think it is correct for the common case.

>
> > +{
> > + if (wait_event_timeout(doe_mb->wq,
> > + test_bit(PCI_DOE_FLAG_CANCEL, &doe_mb->flags),
> > + timeout))
> > + return -EIO;
> > + return 0;
> > +}
>
> > +static int pci_doe_send_req(struct pci_doe_mb *doe_mb,
> > + struct pci_doe_task *task)
> > +{
> > + struct pci_dev *pdev = doe_mb->pdev;
> > + int offset = doe_mb->cap_offset;
> > + u32 val;
> > + int i;
> > +
> > + /*
> > + * Check the DOE busy bit is not set. If it is set, this could indicate
> > + * someone other than Linux (e.g. firmware) is using the mailbox. Note
> > + * it is expected that firmware and OS will negotiate access rights via
> > + * an, as yet to be defined method.
>
> trivial: an, as yet to be defined, method.

I'll send a follow on patch for this.

>
> > + */
> > + pci_read_config_dword(pdev, offset + PCI_DOE_STATUS, &val);
> > + if (FIELD_GET(PCI_DOE_STATUS_BUSY, val))
> > + return -EBUSY;
> > +
> > + if (FIELD_GET(PCI_DOE_STATUS_ERROR, val))
> > + return -EIO;
> > +
> > + /* Write DOE Header */
> > + val = FIELD_PREP(PCI_DOE_DATA_OBJECT_HEADER_1_VID, task->prot.vid) |
> > + FIELD_PREP(PCI_DOE_DATA_OBJECT_HEADER_1_TYPE, task->prot.type);
> > + pci_write_config_dword(pdev, offset + PCI_DOE_WRITE, val);
> > + /* Length is 2 DW of header + length of payload in DW */
> > + pci_write_config_dword(pdev, offset + PCI_DOE_WRITE,
> > + FIELD_PREP(PCI_DOE_DATA_OBJECT_HEADER_2_LENGTH,
> > + 2 + task->request_pl_sz /
> > + sizeof(u32)));
> > + for (i = 0; i < task->request_pl_sz / sizeof(u32); i++)
> > + pci_write_config_dword(pdev, offset + PCI_DOE_WRITE,
> > + task->request_pl[i]);
> > +
> > + pci_doe_write_ctrl(doe_mb, PCI_DOE_CTRL_GO);
> > +
> > + /* Request is sent - now wait for poll or IRQ */
>
> Could drop the IRQ given not currently handling. Though I suppose it's correct
> documentation for this function, so can leave it if preferred.
> More than possible we'll get a follow up patch dropping it though from
> someone doing cleanup.

I send a follow on clean patch for this as well. I suspect IRQ may never make
it in. But for sure it will not for this cycle. Best to have the comment
correct for the final 5.20.

>
> > + return 0;
> > +}
> > +
>
> ...
>
> > +
> > +static void doe_statemachine_work(struct work_struct *work)
> > +{
> > + struct pci_doe_task *task = container_of(work, struct pci_doe_task,
> > + work);
> > + struct pci_doe_mb *doe_mb = task->doe_mb;
> > + struct pci_dev *pdev = doe_mb->pdev;
> > + int offset = doe_mb->cap_offset;
> > + unsigned long timeout_jiffies;
> > + u32 val;
> > + int rc;
> > +
> > + if (test_bit(PCI_DOE_FLAG_DEAD, &doe_mb->flags)) {
> > + signal_task_complete(task, -EIO);
> > + return;
> > + }
> > +
> > + /* Send request */
> > + rc = pci_doe_send_req(doe_mb, task);
> > +
> nitpick, but blank line separating call from error handling reduces
> readability in my opinion.

:-/

I'm not sure why I did this. More clean ups.

>
> > + if (rc) {
> > + /*
> > + * The specification does not provide any guidance on how to
> > + * resolve conflicting requests from other entities.
> > + * Furthermore, it is likely that busy will not be detected
> > + * most of the time. Flag any detection of status busy with an
> > + * error.
> > + */
> > + if (rc == -EBUSY)
> > + dev_err_ratelimited(&pdev->dev, "[%x] busy detected; another entity is sending conflicting requests\n",
> > + offset);
> > + signal_task_abort(task, rc);
> > + return;
> > + }
> > +
> > + timeout_jiffies = jiffies + PCI_DOE_TIMEOUT;
> > + rc = pci_doe_wait(doe_mb, PCI_DOE_POLL_INTERVAL);
>
> What's this particular wait for? I think you can just move directly to checking
> if the response is ready.

We could but I assume it will take at least some time to process the request.
So it seemed best to wait and then check.

But of course we all know that also used to wait for an IRQ as an option. :-/

I'm really on the fence here because I don't think it really matters. We are
sleeping so it does not really affect the system much and this is not a
performance path. If we were spinning I would agree with you.

>
> > + if (rc) {
> > + signal_task_abort(task, rc);
> > + return;
> > + }
> > +
> > + /* Poll for response */
> > +retry_resp:
> > + pci_read_config_dword(pdev, offset + PCI_DOE_STATUS, &val);
> > + if (FIELD_GET(PCI_DOE_STATUS_ERROR, val)) {
> > + signal_task_abort(task, -EIO);
> > + return;
> > + }
> > +
> > + if (!FIELD_GET(PCI_DOE_STATUS_DATA_OBJECT_READY, val)) {
> > + if (time_after(jiffies, timeout_jiffies)) {
> > + signal_task_abort(task, -EIO);
> > + return;
> > + }
> > + rc = pci_doe_wait(doe_mb, PCI_DOE_POLL_INTERVAL);
> > + if (rc) {
> > + signal_task_abort(task, rc);
> > + return;
> > + }
> > + goto retry_resp;
> > + }
> > +
> > + rc = pci_doe_recv_resp(doe_mb, task);
> > + if (rc < 0) {
> > + signal_task_abort(task, rc);
> > + return;
> > + }
> > +
> > + signal_task_complete(task, rc);
> > +}
> > +
>
> > +/**
> > + * pci_doe_supports_prot() - Return if the DOE instance supports the given
> > + * protocol
> > + * @doe_mb: DOE mailbox capability to query
> > + * @vid: Protocol Vendor ID
> > + * @type: Protocol type
> > + *
> > + * RETURNS: True if the DOE mailbox supports the protocol specified
> > + */
> > +bool pci_doe_supports_prot(struct pci_doe_mb *doe_mb, u16 vid, u8 type)
> > +{
> > + unsigned long index;
> > + void *entry;
> > +
> > + /* The discovery protocol must always be supported */
> > + if (vid == PCI_VENDOR_ID_PCI_SIG && type == PCI_DOE_PROTOCOL_DISCOVERY)
> > + return true;
>
> Given how cheap this look up is now it's all in xarray, we could drop this
> 'optimization'. I'm fairly sure the discovery protocol will always be
> discovered (spec says it must be returned when calling itself as the fist
> protocol).

No we can't because this is called before the xarray is populated with the
discovery protocol. This was actually added not as an optimization but to
allow the discovery protocol to run through the common query path.

>
> > +
> > + xa_for_each(&doe_mb->prots, index, entry)
> > + if (entry == pci_doe_xa_prot_entry(vid, type))
> > + return true;
> > +
> > + return false;
> > +}
> > +EXPORT_SYMBOL_GPL(pci_doe_supports_prot);
>
>
> > +EXPORT_SYMBOL_GPL(pci_doe_submit_task);
> > diff --git a/include/linux/pci-doe.h b/include/linux/pci-doe.h
> > new file mode 100644
> > index 000000000000..c77f6258c996
> > --- /dev/null
> > +++ b/include/linux/pci-doe.h
> > @@ -0,0 +1,79 @@
> > +/* SPDX-License-Identifier: GPL-2.0 */
> > +/*
> > + * Data Object Exchange
> > + * PCIe r6.0, sec 6.30 DOE
> > + *
> > + * Copyright (C) 2021 Huawei
> > + * Jonathan Cameron <Jonathan.Cameron@xxxxxxxxxx>
> > + *
> > + * Copyright (C) 2022 Intel Corporation
> > + * Ira Weiny <ira.weiny@xxxxxxxxx>
> > + */
> > +
> > +#ifndef LINUX_PCI_DOE_H
> > +#define LINUX_PCI_DOE_H
> > +
> > +#include <linux/completion.h>
>
> include not needed any more.

Will fix,
Ira

>
> Thanks,
>
> Jonathan
>
> > +
> > +struct pci_doe_protocol {
> > + u16 vid;
> > + u8 type;
> > +};
> > +
> > +struct pci_doe_mb;
> > +
> > +/**
> > + * struct pci_doe_task - represents a single query/response
> > + *
> > + * @prot: DOE Protocol
> > + * @request_pl: The request payload
> > + * @request_pl_sz: Size of the request payload (bytes)
> > + * @response_pl: The response payload
> > + * @response_pl_sz: Size of the response payload (bytes)
> > + * @rv: Return value. Length of received response or error (bytes)
> > + * @complete: Called when task is complete
> > + * @private: Private data for the consumer
> > + * @work: Used internally by the mailbox
> > + * @doe_mb: Used internally by the mailbox
> > + *
> > + * The payload sizes and rv are specified in bytes with the following
> > + * restrictions concerning the protocol.
> > + *
> > + * 1) The request_pl_sz must be a multiple of double words (4 bytes)
> > + * 2) The response_pl_sz must be >= a single double word (4 bytes)
> > + * 3) rv is returned as bytes but it will be a multiple of double words
> > + *
> > + * NOTE there is no need for the caller to initialize work or doe_mb.
> > + */
> > +struct pci_doe_task {
> > + struct pci_doe_protocol prot;
> > + u32 *request_pl;
> > + size_t request_pl_sz;
> > + u32 *response_pl;
> > + size_t response_pl_sz;
> > + int rv;
> > + void (*complete)(struct pci_doe_task *task);
> > + void *private;
> > +
> > + /* No need for the user to initialize these fields */
> > + struct work_struct work;
> > + struct pci_doe_mb *doe_mb;
> > +};
> > +
> > +/**
> > + * pci_doe_for_each_off - Iterate each DOE capability
> > + * @pdev: struct pci_dev to iterate
> > + * @off: u16 of config space offset of each mailbox capability found
> > + */
> > +#define pci_doe_for_each_off(pdev, off) \
> > + for (off = pci_find_next_ext_capability(pdev, off, \
> > + PCI_EXT_CAP_ID_DOE); \
> > + off > 0; \
> > + off = pci_find_next_ext_capability(pdev, off, \
> > + PCI_EXT_CAP_ID_DOE))
> > +
> > +struct pci_doe_mb *pcim_doe_create_mb(struct pci_dev *pdev, u16 cap_offset);
> > +bool pci_doe_supports_prot(struct pci_doe_mb *doe_mb, u16 vid, u8 type);
> > +int pci_doe_submit_task(struct pci_doe_mb *doe_mb, struct pci_doe_task *task);
> > +
> > +#endif
>