Re: [PATCH] infiniband: remove unnecessary null check

From: Leon Romanovsky
Date: Wed Aug 24 2022 - 07:51:36 EST


On Wed, Aug 24, 2022 at 10:15:56AM +0200, Niels Dossche wrote:
> On 8/24/22 10:05, cgel.zte@xxxxxxxxx wrote:
> > From: Minghao Chi <chi.minghao@xxxxxxxxxx>
> >
> > container_of is never null, so this null check is
> > unnecessary.
> >
> > Reported-by: Zeal Robot <zealci@xxxxxxxxxx>
> > Signed-off-by: Minghao Chi <chi.minghao@xxxxxxxxxx>
> > ---
> > drivers/infiniband/sw/rdmavt/vt.c | 2 --
> > 1 file changed, 2 deletions(-)
> >
> > diff --git a/drivers/infiniband/sw/rdmavt/vt.c b/drivers/infiniband/sw/rdmavt/vt.c
> > index 59481ae39505..b2d83b4958fc 100644
> > --- a/drivers/infiniband/sw/rdmavt/vt.c
> > +++ b/drivers/infiniband/sw/rdmavt/vt.c
> > @@ -50,8 +50,6 @@ struct rvt_dev_info *rvt_alloc_device(size_t size, int nports)
> > struct rvt_dev_info *rdi;
> >
> > rdi = container_of(_ib_alloc_device(size), struct rvt_dev_info, ibdev);
> > - if (!rdi)
> > - return rdi;
> >
> > rdi->ports = kcalloc(nports, sizeof(*rdi->ports), GFP_KERNEL);
> > if (!rdi->ports)
>
> I believe this patch is incorrect because "_ib_alloc_device" may return a null pointer.
> Note that the first member of "rvt_dev_info" is "ib_device", so the check on container_of effectively checks if the allocation failed, which is necessary to check.

You are absolutely right, this container_of() and check later are done
on purpose. It is open-coded variant of ib_alloc_device(...) macro.

Thanks