Re: [PATCH -next v2 1/2] riscv: uaccess: rename __get/put_user_nocheck to __get/put_mem_nocheck

From: Andrew Jones
Date: Thu Aug 25 2022 - 06:56:20 EST


On Mon, Aug 15, 2022 at 03:20:24AM +0000, Tong Tiangen wrote:
> Current, The helpers __get/put_user_nocheck() is used by get/put_user() and
> __get/put_kernel_nofault(), which is not always uaccess, so the name with
> *user* is not appropriate.
>
> Also rename xxx_user_xxx to xxx_mem_xx on the call path of
> __get/put_user_nocheck()
>
> Only refactor code without any functional changes.
>
> Signed-off-by: Tong Tiangen <tongtiangen@xxxxxxxxxx>
> ---
> arch/riscv/include/asm/uaccess.h | 48 ++++++++++++++++----------------
> 1 file changed, 24 insertions(+), 24 deletions(-)
>
> diff --git a/arch/riscv/include/asm/uaccess.h b/arch/riscv/include/asm/uaccess.h
> index 855450bed9f5..1370da055b44 100644
> --- a/arch/riscv/include/asm/uaccess.h
> +++ b/arch/riscv/include/asm/uaccess.h
> @@ -50,7 +50,7 @@
> * call.
> */
>
> -#define __get_user_asm(insn, x, ptr, err) \
> +#define __get_mem_asm(insn, x, ptr, err) \
> do { \
> __typeof__(x) __x; \
> __asm__ __volatile__ ( \
> @@ -64,12 +64,12 @@ do { \
> } while (0)
>
> #ifdef CONFIG_64BIT
> -#define __get_user_8(x, ptr, err) \
> - __get_user_asm("ld", x, ptr, err)
> +#define __get_mem_8(x, ptr, err) \
> + __get_mem_asm("ld", x, ptr, err)
> #else /* !CONFIG_64BIT */
> -#define __get_user_8(x, ptr, err) \
> +#define __get_mem_8(x, ptr, err) \
> do { \
> - u32 __user *__ptr = (u32 __user *)(ptr); \
> + u32 *__ptr = (u32 *)(ptr); \

Doesn't casting away __user reduce sparse's utility?

> u32 __lo, __hi; \
> __asm__ __volatile__ ( \
> "1:\n" \
> @@ -88,20 +88,20 @@ do { \
> } while (0)
> #endif /* CONFIG_64BIT */
>
> -#define __get_user_nocheck(x, __gu_ptr, __gu_err) \
> +#define __get_mem_nocheck(x, __gu_ptr, __gu_err) \

The patch replaces all get/put_user instances with get/put_mem,
but what about 'gu' and 'pu' instances (which are presumably short
for get/put_user)?

Thanks,
drew