On 8/24/22 18:42, Asutosh Das (asd) wrote:Ok, makes sense. Will change the name in the next version.
On 8/18/2022 7:41 PM, Bart Van Assche wrote:
On 8/11/22 03:33, Can Guo wrote:The preparatory patch that would precede this change would define ufshcd_compl_one_task() in ufshcd.c. Since this function would be invoked both from Single Doorbell mode and MCQ mode, ufshcd_compl_one_task() sounds more relevant. What say?
+static inline void ufshcd_mcq_process_event(struct ufs_hba *hba,
+ struct ufs_hw_queue *hwq)
+{
+ struct cq_entry *cqe = ufshcd_mcq_cur_cqe(hwq);
+ int tag;
+
+ tag = ufshcd_mcq_get_tag(hba, hwq, cqe);
+ ufshcd_compl_one_task(hba, tag, cqe);
+}
Consider changing "process_event" into "process_cqe". Consider renaming ufshcd_compl_one_task() into ufshcd_compl_one_cqe().
The name "task" is confusing since in SCSI standard documents it refers to "task management" while ufshcd_compl_one_task() is not related to SCSI task management at all. So I would appreciate it if another name is chosen than ufshcd_compl_one_task().