On 8/26/22 09:40, shangxiaojing wrote:
I see, but that is a flag, not the action.again, this is not a good function name. Maybe, dl_replenish_new_period() ?right, i have thought like replenish_new_instance, but when i'm making
patch, i was worried that "replenish" is only for ENQUEUE_REPLENISH.
what about dl_start_new_period? which means a new deadline will be set, rather thanThe thing it is doing is replenishing...
dl_se->deadline += pi_of(dl_se)->dl_period;that is why I added "new_period".... so replenish_dl_new_period() to keep the consistency.
in replenish_dl_entity.
-- Daniel+static inline void start_new_instance(struct sched_dl_entity *dl_se, struct rq *rq)-- Daniel
+{
+ /* for non-boosted task, pi_of(dl_se) == dl_se */
+ dl_se->deadline = rq_clock(rq) + pi_of(dl_se)->dl_deadline;
+ dl_se->runtime = pi_of(dl_se)->dl_runtime;
+}
+