On 8/29/22 12:05, Shang XiaoJing wrote:ok, i like that :-). This will be done in patch v2.
+static inline bool should_push_task_away(struct task_struct *a,static inline bool should_push_task_dl(struct task_struct *curr, struct task_struct *p)
+ struct task_struct *b)
a and b are not good variable names, and add the _dl suffix (instead of away).
+{-- Daniel
+ return unlikely(dl_task(a)) &&
+ (a->nr_cpus_allowed < 2 ||
+ !dl_entity_preempt(&b->dl, &a->dl)) &&
+ b->nr_cpus_allowed > 1;
+}
+