On 09/16/22 13:12, Andrew Morton wrote:Ok, I am going to use available_huge_pages() in the patch v3, thanks.
On Fri, 16 Sep 2022 14:41:27 +0800 Xin Hao <xhao@xxxxxxxxxxxxxxxxx> wrote:How about calling it free_non_reserved_huge_pages() and returning the actual
In hugetlb.c file, there are several places to compare the values ofI'm not sure that's a well chosen name. A better name would reflect
'h->free_huge_pages' and 'h->resv_huge_pages', it looks a bit messy, so
there add a new is_resv_equal_free() func to do these.
...
--- a/mm/hugetlb.c
+++ b/mm/hugetlb.c
@@ -1191,6 +1191,11 @@ static struct page *dequeue_huge_page_nodemask(struct hstate *h, gfp_t gfp_mask,
return NULL;
}
+static inline bool is_resv_equal_free(struct hstate *h)
the *meaning* of free_huge_pages being equal to resv_huge_pages. Maybe
something like reserves_exhausted()?
value (h->free_huge_pages - h->resv_huge_pages)?
Perhaps available_huge_pages()?
It could then be used in at least one other place
- if (h->free_huge_pages - h->resv_huge_pages > 0)
This would all be clearer if we'd bothered to document the fields ofAgree, and discussed elsewhwere some may even be able to be eliminated. I can
struct hstate :(
add that to my todo list.