Re: [PATCH] fs/binfmt_flat.c: use __func__ instead of function name

From: Eric W. Biederman
Date: Mon Sep 19 2022 - 09:52:47 EST


Jiangshan Yi <13667453960@xxxxxxx> writes:

> From: Jiangshan Yi <yijiangshan@xxxxxxxxxx>
>
> It is better to use __func__ instead of function name.

Why?

Usually we leave these kinds of stylistic decisions to the people
actually working on and maintaining the code.

Unless this message is likely to be copied to another function
and it very much does not look like it is, this kind of change
looks like it will just make grepping for the error message more
difficult.

Not that I am working on the code and can speak but this just feels like
a gratuitous change to me and so I am asking questions to make certain
it is actually worth making.

Eric


> Signed-off-by: Jiangshan Yi <yijiangshan@xxxxxxxxxx>
> ---
> fs/binfmt_flat.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/fs/binfmt_flat.c b/fs/binfmt_flat.c
> index c26545d71d39..4104c824e7b1 100644
> --- a/fs/binfmt_flat.c
> +++ b/fs/binfmt_flat.c
> @@ -184,7 +184,7 @@ static int decompress_exec(struct linux_binprm *bprm, loff_t fpos, char *dst,
> z_stream strm;
> int ret, retval;
>
> - pr_debug("decompress_exec(offset=%llx,buf=%p,len=%lx)\n", fpos, dst, len);
> + pr_debug("%s(offset=%llx,buf=%p,len=%lx)\n", __func__, fpos, dst, len);
>
> memset(&strm, 0, sizeof(strm));
> strm.workspace = kmalloc(zlib_inflate_workspacesize(), GFP_KERNEL);