Yeah, this could be another interest set of additions. It seems like it
might be more "coder friendly" if, in the future that has the
__element_count__ attribute, it could be used in function parameters
too, like:
If we had:
int do_something(struct context *ctx, u32 *data, int count)
this seems less easy to read to me:
int __access(read_write, 2, 3) do_something(struct context *ctx, u32 *data, int count)
as this seems more readable to me, though I guess the access-mode
information is lost:
int do_something(struct context *ctx, u32 * __element_count(count) data, int count)