[PATCH v2] Improve comment of get_random_bytes function

From: William Zijl
Date: Sat Oct 01 2022 - 11:36:43 EST


Hi all,

The old comment of this function had a double whitespace and contained
grammatical errors, such as: `the randomness by this function`, `at
least once at any point prior`. Replace those sentences with `the
randomness returned by this function`, `at any point prior to this`
respectively.

Thanks,
Gusted

Signed-off-by: William Zijl <postmaster@xxxxxxxxxx>
---
drivers/char/random.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/char/random.c b/drivers/char/random.c
index fdf15f5c87dd..dd976008136b 100644
--- a/drivers/char/random.c
+++ b/drivers/char/random.c
@@ -382,11 +382,11 @@ static void _get_random_bytes(void *buf, size_t len)
}

/*
- * This function is the exported kernel interface. It returns some
- * number of good random numbers, suitable for key generation, seeding
- * TCP sequence numbers, etc. In order to ensure that the randomness
- * by this function is okay, the function wait_for_random_bytes()
- * should be called and return 0 at least once at any point prior.
+ * This function is the exported kernel interface. It returns some number
+ * of good random numbers, suitable for key generation, seeding TCP
+ * sequence numbers, etc. In order to ensure that the randomness returned
+ * by this function is okay, the function wait_for_random_bytes() should be
+ * called and return 0 at least once at any point prior to this.
*/
void get_random_bytes(void *buf, size_t len)
{
--
2.37.3