[PATCH v2 0/2] Fix error handling for MDP3

From: Moudy Ho
Date: Mon Oct 03 2022 - 03:08:46 EST


Changes since v1:
- Rename goto label in mdp_comp_clock_on() from "err_unwind"
to "err_revert" to make more readable.

Hi,
This series fixes some error handling in MDP3 in response to the bug report
submitted by Dan Carpenter (Message ID = YxB1E00e8D6P4W2e@kili)

Moudy Ho (2):
media: platform: mtk-mdp3: fix error handling in mdp_cmdq_send()
media: platform: mtk-mdp3: fix error handling about components
clock_on

.../platform/mediatek/mdp3/mtk-mdp3-cmdq.c | 51 ++++++++++---------
.../platform/mediatek/mdp3/mtk-mdp3-comp.c | 24 ++++++---
2 files changed, 45 insertions(+), 30 deletions(-)

--
2.18.0