Re: [PATCH v2 2/3] iommu/mediatek: add support for 6-bit encoded port IDs

From: Robin Murphy
Date: Thu Oct 06 2022 - 06:46:53 EST

On 2022-10-04 12:59, AngeloGioacchino Del Regno wrote:
Il 04/10/22 12:01, Alexandre Mergnat ha scritto:
From: Fabien Parent <fparent@xxxxxxxxxxxx>

Until now the port ID was always encoded as a 5-bit data. On MT8365,
the port ID is encoded as a 6-bit data. This requires to rework the
macros F_MMU_INT_ID_LARB_ID, and F_MMU_INT_ID_PORT_ID in order
to support 5-bit and 6-bit encoded port IDs.

Signed-off-by: Fabien Parent <fparent@xxxxxxxxxxxx>
Signed-off-by: Markus Schneider-Pargmann <msp@xxxxxxxxxxxx>
Signed-off-by: Alexandre Mergnat <amergnat@xxxxxxxxxxxx>
  drivers/iommu/mtk_iommu.c | 24 ++++++++++++++++++++----
  1 file changed, 20 insertions(+), 4 deletions(-)

diff --git a/drivers/iommu/mtk_iommu.c b/drivers/iommu/mtk_iommu.c
index 5a4e00e4bbbc..a57ce509c8b5 100644
--- a/drivers/iommu/mtk_iommu.c
+++ b/drivers/iommu/mtk_iommu.c
@@ -108,8 +108,10 @@
  #define F_MMU_INT_ID_SUB_COMM_ID(a)        (((a) >> 7) & 0x3)
  #define F_MMU_INT_ID_COMM_ID_EXT(a)        (((a) >> 10) & 0x7)
  #define F_MMU_INT_ID_SUB_COMM_ID_EXT(a)        (((a) >> 7) & 0x7)
-#define F_MMU_INT_ID_LARB_ID(a)            (((a) >> 7) & 0x7)
-#define F_MMU_INT_ID_PORT_ID(a)            (((a) >> 2) & 0x1f)
+#define F_MMU_INT_ID_LARB_ID(a, int_id_port_width)    \
+                ((a) >> (((int_id_port_width) + 2) & 0x7))
+#define F_MMU_INT_ID_PORT_ID(a, int_id_port_width)    \
+                (((a) >> 2) & GENMASK((int_id_port_width) - 1, 0))

I can't think about any cleaner way than this one, but that's decreasing human
readability by "quite a bit".

In terms of readability, the best thing to do would be define separate macros for each register format and make the choice at the (single) callsite rather than hiding it in the macro. In fact we're already doing exactly that with the HAS_SUB_COMM_2BITS and HAS_SUB_COMM_3BITS flags right at the same point, so please follow that same pattern for consistency.