Re: [PATCH v2] devfreq: Support device update function

From: Johnny Liu
Date: Thu Oct 13 2022 - 01:16:51 EST


Thanks for your quick response and detailed comments. I will prepare a new patch
series to include the user of the proposed function. But still I answer your
concerns in the following sections.

On Thu, 13 Oct 2022 04:44, Chanwoo Choi wrote:
> Hi,
>
> Basically, struct devfreq_dev_profile is used to pass the devfreq device data
> from devfreq driver to governor. But, This means that it passes
> the data from governor to devfreq driver reversely?

Yes, it means that governor can pass data to devfreq driver reversely.

> On 22. 10. 3. 15:02, Johnny Liu wrote:
> > To realize interrupt-driven closed-loop governors, governors need to be
>
> Could you explain the detailed means of 'interrupt-driven closed-loop governors'?

For term "interrupt-driven", it means the DFS logic is triggered by interrupts
rather than performing DFS in a polling fashion. This can reduce the CPU load.

For term "closed-loop", it means that there is a target metric the governor will
try to keep it at certain value/level. For example, if the target metric means
device utilization, then the governor should perform DFS so that it will keep
device utilization at certain level specified by the user.

> > able to send data to the underlying devfreq driver to ask for updating
> > the device settings, such as hardware registers for frequency limits,
>
> I think that governor is not able to get the hardware information direclty
> instead of devfreq driver. Usually, the devfreq driver should get the
> h/w info and then passed to governor if required.

Yes, governor should not be able to the HW info directly. From my perspective,
I think governor should be able to pass down hint, such as device utilization
specified by the user in the governor, to the devfreq driver. Then, the
devfreq driver can configure the device accordingly so that interrupts get
triggered when device utilization exceeds or drops by certain amount.

> Lastly, this patch doesn't contain the any use-case of devfreq_update_dev().
> I prefer to post the real use-case of this patch.

I will include the user of it in a new patch series.

> > which are compared against the device frequency to generate interrupts
> >
> > Since governors might export several tunable parameters, users can
> > enforce different policies for the control logics. Under different
> > policies, governors need to send different information to inform the
> > devfreq driver to configure the device accordingly.
> >
> > The introduced update function improves the flexibility of governors
> > and acts as a communication interface between governors and devfreq
> > drivers.
> >
> > Signed-off-by: Johnny Liu <johnliu@xxxxxxxxxx>
> > ---
> > v2: Correct the function signature of devfreq_update_dev
> >
> > drivers/devfreq/governor.h | 8 ++++++++
> > include/linux/devfreq.h | 8 ++++++++
> > 2 files changed, 16 insertions(+)
> >
> > diff --git a/drivers/devfreq/governor.h b/drivers/devfreq/governor.h
> > index 0adfebc0467a..b5781fa549c7 100644
> > --- a/drivers/devfreq/governor.h
> > +++ b/drivers/devfreq/governor.h
> > @@ -124,4 +124,12 @@ static inline int devfreq_update_stats(struct devfreq *df)
> >
> > return df->profile->get_dev_status(df->dev.parent, &df->last_status);
> > }
> > +
> > +static inline int devfreq_update_dev(struct devfreq *df, void *data)
> > +{
> > + if (!df->profile->update)
> > + return -EINVAL;
> > +
> > + return df->profile->update(df->dev.parent, data);
> > +}
> > #endif /* _GOVERNOR_H */
> > diff --git a/include/linux/devfreq.h b/include/linux/devfreq.h
> > index 34aab4dd336c..91648e8f8d76 100644
> > --- a/include/linux/devfreq.h
> > +++ b/include/linux/devfreq.h
> > @@ -92,6 +92,8 @@ struct devfreq_dev_status {
> > * devfreq.last_status.
> > * @get_cur_freq: The device should provide the current frequency
> > * at which it is operating.
> > + * @update: An optional function to allow governors send data back
> > + * to the devfreq driver to update the device settings.
>
> IMO, 'update' word is too generic. I think that 'update_device_data' is better
> to improve the readability.

Yes, "update_device_data" has better readability compared to "update".

> > * @exit: An optional callback that is called when devfreq
> > * is removing the devfreq object due to error or
> > * from devfreq_remove_device() call. If the user
> > @@ -114,6 +116,7 @@ struct devfreq_dev_profile {
> > int (*get_dev_status)(struct device *dev,
> > struct devfreq_dev_status *stat);
> > int (*get_cur_freq)(struct device *dev, unsigned long *freq);
> > + int (*update)(struct device *dev, void *data);
> > void (*exit)(struct device *dev);
> >
> > unsigned long *freq_table> @@ -451,6 +454,11 @@ static inline int devfreq_update_stats(struct devfreq *df)
> > {
> > return -EINVAL;
> > }
> > +
> > +static inline int devfreq_update_dev(struct devfreq *df, void *data)
> > +{
> > + return -EINVAL;
> > +}
> > #endif /* CONFIG_PM_DEVFREQ */
> >
> > #endif /* __LINUX_DEVFREQ_H__ */

--
Best Regards,
Johnny Liu