[PATCH 2/4] mm/slub: rename kmem_cache_release to slab_release in slub.c

From: Liu Shixin
Date: Mon Oct 24 2022 - 02:54:15 EST


The function name kmem_cache_release has been reused in slab_common.c and
slub.c which is easy to misunderstand. Rename the kmem_cache_release to
slab_release in slub.c to distinguish them.

Signed-off-by: Liu Shixin <liushixin2@xxxxxxxxxx>
---
mm/slub.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/mm/slub.c b/mm/slub.c
index 157527d7101b..ba94eb6fda78 100644
--- a/mm/slub.c
+++ b/mm/slub.c
@@ -5847,7 +5847,7 @@ static ssize_t slab_attr_store(struct kobject *kobj,
return attribute->store(s, buf, len);
}

-static void kmem_cache_release(struct kobject *k)
+static void slab_release(struct kobject *k)
{
slab_kmem_cache_release(to_slab(k));
}
@@ -5859,7 +5859,7 @@ static const struct sysfs_ops slab_sysfs_ops = {

static struct kobj_type slab_ktype = {
.sysfs_ops = &slab_sysfs_ops,
- .release = kmem_cache_release,
+ .release = slab_release,
};

static struct kset *slab_kset;
--
2.25.1