Re: [PATCH 2/2] virtio_ring: use helper function is_power_of_2()

From: Xuan Zhuo
Date: Mon Oct 24 2022 - 07:35:35 EST


On Thu, 20 Oct 2022 23:27:34 -0700, shaoqin.huang@xxxxxxxxx wrote:
> From: Shaoqin Huang <shaoqin.huang@xxxxxxxxx>
>
> Use helper function is_power_of_2() to check if num is power of two.
> Minor readability improvement.
>
> Signed-off-by: Shaoqin Huang <shaoqin.huang@xxxxxxxxx>
Reviewed-by: Xuan Zhuo <xuanzhuo@xxxxxxxxxxxxxxxxx>
> ---
> drivers/virtio/virtio_ring.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/virtio/virtio_ring.c b/drivers/virtio/virtio_ring.c
> index 2e7689bb933b..723c4e29e1d3 100644
> --- a/drivers/virtio/virtio_ring.c
> +++ b/drivers/virtio/virtio_ring.c
> @@ -1052,7 +1052,7 @@ static int vring_alloc_queue_split(struct vring_virtqueue_split *vring_split,
> dma_addr_t dma_addr;
>
> /* We assume num is a power of 2. */
> - if (num & (num - 1)) {
> + if (!is_power_of_2(num)) {
> dev_warn(&vdev->dev, "Bad virtqueue length %u\n", num);
> return -EINVAL;
> }
> --
> 2.34.1
>
> _______________________________________________
> Virtualization mailing list
> Virtualization@xxxxxxxxxxxxxxxxxxxxxxxxxx
> https://lists.linuxfoundation.org/mailman/listinfo/virtualization