Re: [PATCH v3 02/17] ufs: core: Optimize duplicate code to read extended feature

From: Bart Van Assche
Date: Thu Oct 27 2022 - 17:10:29 EST


On 10/20/22 11:03, Asutosh Das wrote:
The code to parse the extended feature is duplicated more then 2
times in the ufs core. Replace the duplicated code with the
function.

Signed-off-by: Asutosh Das <quic_asutoshd@xxxxxxxxxxx>
---
drivers/ufs/core/ufshcd.c | 10 ++--------
1 file changed, 2 insertions(+), 8 deletions(-)

diff --git a/drivers/ufs/core/ufshcd.c b/drivers/ufs/core/ufshcd.c
index 80f01d0..e2be3f4 100644
--- a/drivers/ufs/core/ufshcd.c
+++ b/drivers/ufs/core/ufshcd.c
@@ -7605,13 +7605,7 @@ static void ufshcd_wb_probe(struct ufs_hba *hba, const u8 *desc_buf)
(hba->dev_quirks & UFS_DEVICE_QUIRK_SUPPORT_EXTENDED_FEATURES)))
goto wb_disabled;
- if (hba->desc_size[QUERY_DESC_IDN_DEVICE] <
- DEVICE_DESC_PARAM_EXT_UFS_FEATURE_SUP + 4)
- goto wb_disabled;
-
- ext_ufs_feature = get_unaligned_be32(desc_buf +
- DEVICE_DESC_PARAM_EXT_UFS_FEATURE_SUP);
-
+ ext_ufs_feature = ufs_get_ext_ufs_feature(hba, desc_buf);
if (!(ext_ufs_feature & UFS_DEV_WRITE_BOOSTER_SUP))
goto wb_disabled;
@@ -7665,7 +7659,7 @@ static void ufshcd_temp_notif_probe(struct ufs_hba *hba, const u8 *desc_buf)
if (!(hba->caps & UFSHCD_CAP_TEMP_NOTIF) || dev_info->wspecversion < 0x300)
return;
- ext_ufs_feature = get_unaligned_be32(desc_buf + DEVICE_DESC_PARAM_EXT_UFS_FEATURE_SUP);
+ ext_ufs_feature = ufs_get_ext_ufs_feature(hba, desc_buf);
if (ext_ufs_feature & UFS_DEV_LOW_TEMP_NOTIF)
mask |= MASK_EE_TOO_LOW_TEMP;

Ah, that's the change I asked for in my reply to the previous patch :-)

Shouldn't patches 01/17 and 02/17 be reordered?

`git rebase -i` should make it easy to reorder these two patches.

Thanks,

Bart.