Re: [PATCH v2 12/12] use less confusing names for iov_iter direction initializers

From: David Howells
Date: Fri Oct 28 2022 - 13:06:23 EST


Linus Torvalds <torvalds@xxxxxxxxxxxxxxxxxxxx> wrote:

> Honestly, I think the *real* fix would be a type-based one. Don't do
>
> iov_iter_kvec(&iter, ITER_DEST, ...
>
> at all, but instead have two different kinds of 'struct iov_iter': one
> as a destination (iov_iter_dst), and one as a source (iov_iter_src),

Or maybe something along the lines of iov_iter_into_kvec() and
iov_iter_from_kvec()?

Also, would it make sense to disallow asking the iterator for its direction
entirely and only use it for internal sanity checking? In many of the places
it is looked at, the information is also available in another form (the
IOCB_WRITE flag, for example).

David