Re: [PATCH] staging: rtl8723bs: Replace ternary statement with min function

From: Emily Peri
Date: Fri Oct 28 2022 - 13:21:36 EST


On Thu, Oct 27, 2022 at 08:12:14AM +0200, Julia Lawall wrote:
>
>
> On Wed, 26 Oct 2022, Emily Peri wrote:
>
> > Ternary statements that pick the min of two values can be replaced by
> > the built-in min() function. This improves readability, since its quicker
> > to understand min(x, y) than x < y ? x : y. Issue found by coccicheck.
>
> It looks like a nice change, but I get a compiler error afer the patch,
>
> julia

Okay, I think I know the issue. Another person commented (Dan Carpenter)
that the function needs to be min_t, I'm guessing so the function
returns the value as the correct type. But one thing I'm wondering is,
why I didn't I get a compiler error when I compiled the kernel myself?

Also-- this is just a general question, when we work on drivers I'm
guessing we don't need to include header files from include/linux,
right?

> >
> > Signed-off-by: Emily Peri <eperi1024@xxxxxxxxx>
> > ---
> > drivers/staging/rtl8723bs/os_dep/ioctl_cfg80211.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/drivers/staging/rtl8723bs/os_dep/ioctl_cfg80211.c b/drivers/staging/rtl8723bs/os_dep/ioctl_cfg80211.c
> > index 6aeb169c6ebf..0cf7d9f82b83 100644
> > --- a/drivers/staging/rtl8723bs/os_dep/ioctl_cfg80211.c
> > +++ b/drivers/staging/rtl8723bs/os_dep/ioctl_cfg80211.c
> > @@ -1551,7 +1551,7 @@ static int rtw_cfg80211_set_wpa_ie(struct adapter *padapter, u8 *pie, size_t iel
> >
> > wps_ie = rtw_get_wps_ie(buf, ielen, NULL, &wps_ielen);
> > if (wps_ie && wps_ielen > 0) {
> > - padapter->securitypriv.wps_ie_len = wps_ielen < MAX_WPS_IE_LEN ? wps_ielen : MAX_WPS_IE_LEN;
> > + padapter->securitypriv.wps_ie_len = min(wps_ielen, MAX_WPS_IE_LEN);
> > memcpy(padapter->securitypriv.wps_ie, wps_ie, padapter->securitypriv.wps_ie_len);
> > set_fwstate(&padapter->mlmepriv, WIFI_UNDER_WPS);
> > } else {
> > --
> > 2.34.1
> >
> >
> >