Re: [PATCH] staging: rtl8723bs: Replace ternary statement with min function

From: Emily Peri
Date: Fri Oct 28 2022 - 13:52:11 EST


On Thu, Oct 27, 2022 at 10:32:15AM +0300, Dan Carpenter wrote:
> On Wed, Oct 26, 2022 at 06:26:54PM -0700, Emily Peri wrote:
> > Ternary statements that pick the min of two values can be replaced by
> > the built-in min() function. This improves readability, since its quicker
> > to understand min(x, y) than x < y ? x : y. Issue found by coccicheck.
> >
> > Signed-off-by: Emily Peri <eperi1024@xxxxxxxxx>
>
> This breaks the build. Use min_t(uint, wps_ielen, MAX_WPS_IE_LEN);
>
> regards,
> dan carpenter

Oh! Thanks for the feedback, that makes sense! When you say 'breaks the
build,' do you mean it didn't compile, or the module didn't load (or
something else)? I'm trying to figure out what I did wrong when testing
it.

Best,
Emily