Re: [PATCH-next] lib: parser: optimize match_NUMER apis to use local array

From: lilingfeng (A)
Date: Fri Dec 09 2022 - 21:51:41 EST



在 2022/12/10 0:57, Tejun Heo 写道:
Hello,

In general, I think this is a great idea. Some nits below:

On Fri, Dec 09, 2022 at 02:34:34PM +0800, Li Lingfeng wrote:
+/*
+ * max size needed by diffrent bases to express U64
+ * HEX: "0xFFFFFFFFFFFFFFFF" --> 18
+ * DEC: "18446744073709551615" --> 20
+ * OCT: "01777777777777777777777" --> 23
+ * pick the max one to define U64_MAX_SIZE
+ */
+#define U64_MAX_SIZE 23
Bikeshedding but how about naming it like NUMBER_BUF_LEN and including the
space for '\0'? Or just give it some extra space and make it 32 bytes.
Yes, it's my mistake, I'll send a new patch soon.
+static int match_strdup_local(const substring_t *s, char *buf)
I find it weird to name this as generic as match_strdup_local() and make it
assume that the buffer length is U64_MAX_SIZE + 1. Maybe just let the caller
pass in the buffer length as a parameter? Then, it's just strcpy and there
already is match_strlcpy() so we don't need this at all.

Thank you for your advice. But I think match_number() is aimed to turn the
string to num, so maybe it's better to return an error code rather than
using match_stlcpy() to truncate it to give a wrong num when the string
is too long to store.

+{
+ size_t len = s->to - s->from;
+
+ if (!s->from)
+ return -EINVAL;
If we use match_strlcpy() we lose the above null check but given that other
match_*() functions aren't doing it, this likely shouldn't matter.

Like this:
match_strdup
 kmemdup_nul
  if (!s) // null check has been done here
   return NULL
So I think null check may be necessary.

Thanks.

Thanks.