[PATCH v6 0/4] ufs: core: Always read the descriptors with max length

From: Arthur Simchaev
Date: Wed Dec 14 2022 - 04:50:37 EST


v5--v6:
Add Bart's "Reviewed-by" to patch 2 and 4

v4--v5:
Change patch 2 according to Bart's comment

v3--v4:
Add "Reviewed-by" to patch's commits
Use kzalloc instead of kmalloc in drivers/ufs/core/ufshcd.c - patch 2/4

v2--v3:
Based on Bean's comments:
1)Use kzalloc instead of kmalloc in ufshcd_set_active_icc_lvl - patch 2/4
2)Delete UFS_RPMB_UNIT definition - patch 2/4
3)Delete len description - patch 3/4

v1--v2:
Fix argument warning in ufshpb.c

Read any descriptor with a maximum size of QUERY_DESC_MAX_SIZE.
According to the spec the device rerurns the actual size.
Thus can improve code readability and save CPU cycles.
While at it, cleanup few leftovers around the descriptor size parameter.

Suggested-by: Bean Huo <beanhuo@xxxxxxxxxx>

Arthur Simchaev (4):
ufs:core: Remove redundant wb check
ufs:core: Remove redundant desc_size variable from hba
ufs: core: Remove len parameter from ufshcd_set_active_icc_lvl
ufs: core: Remove ufshcd_map_desc_id_to_length function

drivers/ufs/core/ufs_bsg.c | 7 +--
drivers/ufs/core/ufshcd-priv.h | 3 --
drivers/ufs/core/ufshcd.c | 100 ++++++++++-------------------------------
drivers/ufs/core/ufshpb.c | 5 +--
include/ufs/ufshcd.h | 1 -
5 files changed, 26 insertions(+), 90 deletions(-)

--
2.7.4