Re: [PATCH v6 01/34] vfs: Unconditionally set IOCB_WRITE in call_write_iter()

From: David Howells
Date: Tue Jan 17 2023 - 06:12:39 EST


Christoph Hellwig <hch@xxxxxxxxxxxxx> wrote:

> I suspect the best is to:
>
> - rename init_sync_kiocb to init_kiocb
> - pass a new argument for the direction to it. I'm not entirely
> sure if flags is a good thing, or an explicit READ/WRITE might be
> better because it's harder to get wrong, even if a the compiler
> might generate worth code for it.

So something like:

init_kiocb(kiocb, file, WRITE);
init_kiocb(kiocb, file, READ);

David